KILL caused by kill button/pin.

Hello,

I am suddenly getting the following error after starting up.

Killed.

Printer halted.

please reset

plus a loud sustained beep from the lcd. I unplugged the lcd and was able to connect with cncjs but a few seconds after connecting I get a similar error in the console. Any ideas?

 

 

What software and firmware are you using, does my crown gcode do the same thing?

302… 2.0 Bugfix… It’s the one that shipped with the board. Full Rambo but not dual firmware. I’m using cncjs connected via usb. It has previously worked fine on this setup. I can’t get far enough to load any gcode. It just goes to the error within 2 seconds of booting up. All the fuses look ok although I’m not sure how the little ones look when blown.

It sounds like somehow pin 80 is shorted to ground. The button on the LCD should normally be configured to the KILL function, but if it still triggers the kill function with the LCD unplugged then it can’t be the LCD. My LCD button is normally open and shorts one side to ground when pressed.

If you can double check that you have the problem when LCD is disconnected, and that you are running the RAMBO firmware, you can try this:

  • download the rambo firmware and go into Marlin\src\pins\pins_RAMBO.h
  • on line 167, comment out "#define KILL_PIN 80", i.e. change it to "//#define KILL_PIN 80"
  • flash firmware and see if it makes a difference. It should disable the kill pin (supposed to be on the LCD but could be shorted somehow.)
 
1 Like

Hello… Thanks for the idea on disabling pin 80. I tried to flash the firmware, but it failed. If I open up the Serial monitor in Arduino IDE, i get the same kill() message shortly after powering on the board. Here is the error when trying to upload the firmware:

Arduino: 1.8.9 (Windows Store 1.8.21.0) (Windows 10), Board: “RAMBo”

sketch\src\lcd\ultralcd.cpp: In function ‘status_printf_P.constprop’:

sketch\src\lcd\ultralcd.cpp:1268:3: internal compiler error: Segmentation fault

}

^

Please submit a full bug report,

with preprocessed source if appropriate.

See <http://gcc.gnu.org/bugs.html> for instructions.

lto-wrapper.exe: fatal error: C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.21.0_x86__mdqgnx93n4wtt\hardware\tools\avr/bin/avr-gcc returned 1 exit status

compilation terminated.

c:/program files/windowsapps/arduinollc.arduinoide_1.8.21.0_x86__mdqgnx93n4wtt/hardware/tools/avr/bin/…/lib/gcc/avr/5.4.0/…/…/…/…/avr/bin/ld.exe: error: lto-wrapper failed

collect2.exe: error: ld returned 1 exit status

Multiple libraries were found for “U8glib.h”
Used: C:\Users\Brian\Documents\Arduino\libraries\U8glib
Not used: C:\Users\Brian\Documents\ArduinoData\packages\rambo\hardware\avr\1.0.1\libraries\U8glib
exit status 1
Error compiling for board RAMBo.

Just to be clear, I’ve ruled out the LCD by completely disconnecting it. I get the same kill error in the attached pics above in cncjs and Arduino serial monitor on 2 different PCs. This error happens upon bootup. I am unable to issue any commands after it occurs. It appears to also be reason I cannot flash new firmware to it.

I hear what you’re saying. I agree it’s not the LCD.

The “internal compiler error: Segmentation fault” is something I’ve seen on the newer Arduino releases and it’s annoying. Sometimes if I try multiple times it will succeed. Another option, also annoying, is to try reinstalling Arduino 1.8.9 and the ug8lib and extra boards as described in the instructions (https://www.v1engineering.com/marlin-firmware/). You could also try the non-windows-store version, which is just a zip file you can run without installing.

If you compile and you see error without an “internal compiler error” then post that here and we can diagnose more from there.

1 Like

Progress!

After reinstalling Arduino IDE (non Windows Store version) AND turning on verbose mode for compilation and uploading, I was able to get the firmware to load. I was then able connect via cncjs and jog the machine around. I thought GREAT problem resolved… and decided to plug in the LCD again. The LCD now boots up to the normal screen however the alarm is still blarring from it. Is that another PIN i need to disable?

I don’t know if this will help or not but the last time I saw that happen it turned out to be one of the LCD cables was backwards. That is what caused the Kill and the beeping. But since you said it happened with the LCD detached I am not sure. If they two cases are related.

Within pins_RAMBO.h look for beeper pin. I think its the one where it says

#define BEEPER_PIN 79 // AUX-4

but im not 100% sure. You can disable all 3 occurrences of beeper pin and save some trial and error.

Also note this is a workaround for a “bad” board. You should probably also look for a root cause, how did those pins get shorted?

I get a similar issue. I unplug the the LCD and run the cnc as soon as i plug it back in I get the error both on the LCD and Repetier-Host.

it used to be fine. The only thing that happened I had a card in the reader when I booted up. There was only 1 gcode file on the the card.

Any help to fix this would be greatly appreciated.

no idea how it got shorted… i had the case open because I was installing a switch between the power supply and board. Yes power was unplugged when I did it.

Is it possible there are faulty boards? Looking at Nick’s join date we probably bought the boards around the same time.

I would agree with faulty board. Did not change or touch anything as far as the boards goes. It worked in the evening. and when I started it up in the morning I had the error. As I said the only thing that was different I had an SD card in it when I started up. I ordered a new display ($15) and will see if that solves the problem. I need the display for tool changes… :frowning:

Yes it is a faulty board. Bought a new one ind it is working fine now.