LCD Axis Control increments = 4 times what they should me

Hi all,

Just finished building my MPCNC.

Bought the kit from the website and got it wired up and working great with an LCD. Manual access control worked perfectly, checked the accuracy of movement by marking the rails and moving by 10mm increments. Spot on. Then, fried the Arduino by shorting the GND and 5V.

Have now replaced the Mega and flashed R7. It’s working fine, with the exception of the LCD axis movement is moving the rails 4 times the amount they should.

eg. X/Y 10mm = moves the rail 40mm.
Z 1mm = moves 4mm

I should point out that the machine knows it’s doing this and the number given is in 40/4/0.4 increments, and the machine is drawings with great accuracy. Just confused why it is doing this…

any ideas?

Solved the issue by cloning the old Arduino, but still interested if anyone knows why what I was describing was happening.

Each detent on the dial is actually 4 spots on the encoder. If you move the dial a little without letting it click to the next spot it will only move 10/1/.1. Mine does this but I haven’t fixed it in the firmware yet.