LR2 finishes cut, 99% on screen and doesn't move anymore!

Hi guys,

I have a weird problem with my CNC which annoys quite a lot when you want to just cut some stuff.
I start the cut, it cuts completely to the end (really fulfills the whole job and goes back to 0/0). That’s already good, happy that I got so far :smile: However the screen remains on 99%. I can “resume” the print, but nothing happens. When I stop it, the “cutting process” screen disappears and I can click trough the menu, however the machine does not react on any commands anymore - can’t move the machine or start a new cut. At the beginning I restarted the whole machine, in the meanwhile I already figured out that it is enough to click the reset button of the screen.

So here is my setup:

  • LowRider 2 CNC build with dual end stops
  • Mainboard - SKR Pro v1.2
  • Stepper - 17HS19
  • Driver - TMC5160
  • Router - Makita RT0700C
  • ESP-01S ESP8266 WIFI Module
  • TFT35 V 2.0 Touchscreen

I create all my design and machine code with:

  • Autodesk Fusion 360 using
  • Post-processor from flyfisher604

Thank in advance for your help!
Sebastian

Possibly a Gcode / MCode command causing issues at the end of the run?
Can you include a sample job?, I had issues with my machine not shutting down the spindle properly.
I got it working by altering the end of job script in Repetier Host to shut it down and home properly.

1 Like

I had the same issue - commenting out all the end of run code resulted in 100% complete

1 Like

I also think this is likely a gcode issue. Since there’s no mention of a gcode sender, I’ll assume this is just done from an sdcard and there’s no issues with config on the sender end. Can you post a sample gcode file? I also use f360+flyfisher’s PP, and here’s a snippet from the end of a successful cut I did:

G0Z7
M9
G1S0
M5
G90
; return to user-defined finish pos
G0 X0 Y0

;USER END SCRIPT
M63 P0
;USER END SCRIPT
M2

My guess is you may have something like M84 in your end code. Note M2 is the supported end of file command for GRBL, which is what I’m using. Marlin doesn’t support M2. Traditionally ISO gcode files start and end with a “%”; not sure if marlinfw supports that, but can’t hurt to try.

…or, maybe it’s just you can’t resume a print when you are cutting on a cnc. :stuck_out_tongue_winking_eye:

2 Likes


Thank you all for the prompt replies. Here some screenshots of the .gcode. Indeed, this might be the root cause. But how can I get rid of the unwished code, without removing the lines manually?

It is the M400 I think that needs to be removed. Not sure why it is there because flyfishers pp has no start end gcodes by default.

To verify your settings, open the pp in f360, click the pencil to edit the pp, and find the line that starts with “gcodeStopFile:”. It has the filename the pp will look for when it adds end gcodes. That line should be blank. If it is not, we locate that file… open the pp, and click the button to open the output folder. This is the directory where the pp looks for the various start and end files. You may have a file in there matching the filename in the pp with m400 in it… delete that line and save the file.

If this doesn’t get you anywhere, you may be using a different version of the pp than I am. I’m running I think version 21 (named mpcnc21 but not totally sure).

I guess the M 400 is okay, as it still moves to X0 Y0 after the job. However yes, I don’t need this command. Is tried to check what you mentioned, however it doesn’t seem that it takes a gcodeStopFile as there is no path.

The version I’m using is freshly downloaded from the forum yesterday, version 2.1.


M0 is pause. It is asking you to turn off the spindle and then you have to click ok somewhere (depending on where the gcode is coming from).

1 Like

That sounds plausible. I put the gcode-file on the SD card and put it into the slot of the display unit. Then is chose cut in the display-menu and start the milling process from the SD card on the touchscreen.

The touch screen should have a print out that says “Turn Off Spindle” and “ok”. But it may also have made it through to Marlin. In which case, there is a similar screen in Marlin Mode.

Sorry about the incorrect info WRT M400. I think your PP is setup as expected; I am pretty sure blank is the default, and you have to add a path there if you want to use startup or end gcodes. Again, apologies for the distraction, but hey knowing how f360 does start/stop codes may be useful later on.

To keep you updated, first of all here a small photostory of my experiments. These are all the prompts I get from start to end of a 2D contour cut.







After all, it is exactly how you said. Unfortunately, in 50% of the cuts the display gets hung up during the last prompts / after confirming them. I can then still walk trough the menu, but the machine ignores any further input from my side to move around. For now, I just stripped down the gcode manually to the minimum and everything went fine. However, I would prefer that the gcode is created without the unnecessary lines. Is there any way to edit / customize the post-processor from flyfisher604 in this direction?

It is weird that it isn’t deterministic. But if the screen is sending anything to Marlin, you have to use marlin mode to clear the pause.

As far as I understood from other Threads, with the TFT35 V 2.0 I use there is no possibility to enter Marlin Mode, right?

Yes it’s possible, tricky but possible with some kind of rotary encoder emulation and soldering: