Mintemp setting caused ramps destruction

I recently killed something on my ramps setup from my MPCNC. I have a Printrite DIY printer I picked up cheap. Paired with Simplify 3D it printed incredibly well, until the main board failed and a new one was like $80. After research I found that most people just switch to ramps anyway because the oem board is plagued with issues.

So I borrowed the ramps setup from my mpcnc since I didn’t have any projects lined up for it anyway. I took the firmware that most people used and modified it by using the extruder settings from Ryan’s firmware since that was the extruder I was putting on it. I didn’t feel like connecting everything when I was playing with the firmware so I just connected the LCD and power. Min temp error showed up. I figured that an easy fix to make it go away was to set it to 0 since I didn’t have anything connected. Well, it worked for a few seconds. I turned around to pick up something that I dropped and when I looked back at the ramps board it was letting out the magic smoke.

I don’t think I have ever unplugged something from my computer so quickly or violently before. Then I disconnected the main power. I’m not really sure if it was the arduino, ramps board, or both that died. As long as the stepper drivers are fine, it is super cheap to get a new arduino mega clone and ramps board.


Anyone know why changing the extruder min temp setting to 0 would cause that? Literally nothing else was plugged in (power, usb, and LCD) and the board was on a non conductive surface.

It was looking for a thermistor, so plugging in the thermistor or changing the firmware to thermistor value 998 would have been the better way. Neither the min temp error or changing it to 0 should have caused any issues though. Unplugging/plugging in a stepper while powered can kill a driver, and drawing too much power can kill a 5v reg, or a mosfet, but with nothing plugged in there is no way to kill the board with physically shorting something. Was is sitting on a conductive surface, or maybe you tried to power the green plug and the mega barrel jack at the same time?

Any idea where the smoke came from?

I could see changing the software might have turned on the heatbed, or the extruder heater, and if your mosfets were touching, that might have been their first change to melt. If the set temp was 0, and the temperature was reading -1, it might turn on the heater, but that’s a long shot. I’m just guessing here.

Definitely not on a conductive surface. Only connected through green plug for power and usb for uploading the firmware.

I can’t find any visible damage to the arduino or ramps board. I am tempted to update the firmware on just the arduino (if it works) and then reconnect it the way it was. But having seen the smoke come out, I could never trust it without sitting right there.