Motors not moving and driver issues

Bought my kit from here. I have a RepRap Mendel that I printed my parts with. Since both machines use the same RAMPS setup, I didn’t think I would have any troubles. But when I first plugged in the board, my computer picked it up as USB2.0 Serial. Not sure why it didn’t use the RRD_RUMBA_TAURINO_DriverSetup drivers that my other board uses. Looked around on here for an answer. Found this thread
Tried that driver. Now it comes up as USB-SERIAL CH340 (COM22).

Ok, so when I tell Repetier to connect on COM22, it connects. But I get no manual control. Instead I get Communication timeout - reset send buffer block.

So, I have some experience with a similar machine and thought that since I bought the kit from you this would be kind of plug in and go. Hope you can help me out.

Do you have the resistor plugged in or is it giving a max temp error and disconecting? The standard arduino drivers should work. Baud rate of your repetier?

PC or MAC?

Did not have resistor plugged in. My bad. Plugged it in. Still no action.

This is a PC Win 7. Baud rate set to 115200.

I’ve previously used Repetier a few times but have preferred slic3r for slicing my print files and then I print from the lcd RepRapDiscount Smart Controller. Is your firmware setup for lcd? Can I plug it in and control directly from that?

When I connect in Repetier, I get: No start signal detected - forcing start.

Then any manual commands do not get sent and I get the communication timeout.

That is the wrong baud rate, the default is 250000.

Thanks. That has got me manual control. I’m sure the rest will come together now.