MPCNC ramps 1.4 board shut down laptop

I recently bought “Mostly Printed CNC Parts Bundle” and when I got everything ready I plugged it in to my laptop and the laptop shut down and now it wont turn on.

Had the same thing happen to me yesterday after moving my machine to work for a project. I had been using it fine for a months prior.

Heres what happened…

I needed to update the firmware on the 2560, so I pulled out my laptop and plugged it in. The 12V was plugged into the wall as well. As soon as i inserted the usb cable, the laptop shut off.

Upon review I had toasted the USB chip in the Mega.

I found that I had the machine plugged into one separate circuit, and the laptop plugged into another circuit on a separate phase.

Because of this, I created a ground differential between the 12v rail and the laptop usb ground. This essentially backfed more voltage into the usb chip on the mega shorting it out.

I ended up replacing the surface mount USB chip because I have the tools and re-flashed the bootloader, it worked fine since.

Moral of the story, check your ground potential. I stumbled upon this with a quick google. You could simply have the 12v wiring backwards, you could be on separate circuits, or you could have a ground potential problem.

Hopefully your laptop is okay… Try to hold the power down and force it off/back on. Mine took the hit, hope yours does too.

Now the laptop won’t turn on, or the ramps won’t turn on?

Can we see the power plug as well?

My laptop has a tiny little reset/battery disconnect button on the bottom any time I do anything funky that does the trick.

I tried plugging it in again and the board started smoking

That white stuff isn’t from smoke that is pcb cleaner residue.

Look at the top of your 5v regulator for a hole?

Did you make sure they were plugged into the same outlet, Jason’s comment is 100% accurate?

You bought it from me and it is 100% tested on an actual mpcnc with an lcd screen (the highest load you can give it all three axis full speed) and this sort of catastrophic failure shouldn’t happen.

Have you plugged in anything else?

That case isn’t printed with conductive filament is it?

If you don’t think you have done anything out of the ordinary you can send it in and I will fix it.

I added some wire extenders but other than that I haven’t change anything. The laptop and the board were plugged into the same outlet, and the case was printed out of PLA.

  1. is the laptop okay? Remove battery, hold power, etc...
  2. Second, i did a few things once I realized that my computer was okay. check the components one at a time. Be ready to unplug.
plug in the arduino ONLY (NO RAMPS) (NO RAMPS PWR) to the computer Does it acknowledge that a usb device has been connected? (Check device manager if nothing pops up) Now try the ramps with the arduino to usb, (STILL NO RAMPS PWR) . Anything? Next do Arduino,Ramps,LCD (STILL NO RAMPS PWR) . Anything? Now try Arduino,Ramps,LCD with ramps power (UNPLUG USB!!!!!) . Anything?