New 96x48 Lowrider with Y axis issue

While checking out my new build, I ran the gantry 2438.4 mm (via the LCD) down the Y axis then measured the distance and it was about 1/4 inch short (6-7 mm) short of 8 feet. Is this expected?

Mini-rambo controller with Marlin bugfix-2.0.x firmware flashed by V1. All parts, including steppers, idlers, pulleys and belts were bought from V1 in Aug of '18.


Hmm. Not expected. The motors have exactly 200 steps per rotation (not 200.01), the pulleys have exactly 16 teeth. So they should be able to move exactly the correct number of teeth over enormous distances.

The only “analog” factor is the belts. They are supposed to have 2mm per tooth. They are reinforced with fiber inside the rubber. So they are hard to stretch beyond their intended length.

But I am not sure what the actual tolerances are for the belts. They may never have been intended to be that accurate over 8’.

There is a cheap fix though. You can just adjust the steps/mm in the firmware and it will know to add a few steps when traveling that far and it should be able to close that gap of 6mm.

6mm/2438.4 = 0.0025

100*1.0025 = 100.25

So changing your steps/mm to 100.25 should be close. It will add 0.25mm for every 100mm you travel.

1 Like

Before adjusting the steps per mm setting, make sure you’ve eliminated mechanical issues. By far the most common cause of mechanical slop in new builds are loose set screws in the pulleys. Make sure there’s a set/grub screw tightened on the flat of the shaft and if there’s another it should be snug as well. A small dab of temporary thread locker (e.g. blue locktite) can keep them from working loose over time.


M92 Y100.26 did the trick. I can now reliably run the full length of the table in both directions and the stop points are spot on. Thank you!

I seems my belts are slightly short of the specs (though maybe within an accepted manufacturing tolerance?).

I tried writing the step value to EEPROM with M500 but octoprint reported an error. So I’m planning on adding M92 to my Program Start commands in Estlcam.

Now on to checking out the X axis…


1 Like