No motor movement

So I went to test the movement of the motors for them not to move at all.

There is no timing belt is attached at this point (wanted to give a test before finalizing the assembly) and downloaded the Arduino software and repeater host.

The motors were wired up in series, so to troubleshoot, i disconnected the wiring harness and plugged only one motor of each axis in, still no movement.

So am i missing a step? I was under the presumption that this would be more plug and play since the board (mini rambo) has already been flashed with the firmware.

Is the board powering up? Should see some LEDs light up.

The board has power (LEDs are lit up)

I'm thinking its something regarding the computer to board, not board to steppers.

Please provide more specifics:
Type/configuration and flavor of controller (RAMPS, Rambo, Vanilla?)
Did you opt for the LCD and if so, does it startup with the Marlin and V1 Engineering logos? Side note: an LCD would help determine if it’s your PC, connection or the controller (since you can control movement with the LCD without a PC connected).
Pictures of your wiring to/from the controller
Which firmware are you loading (non-dual end-stop or end-stop?)

1 Like


mini rambo -

I bought this kit in particular -

no LCD (will buy to troubleshoot though)

firmware is what was pre-flashed from v1 - “This board will be pre-flashed with The Mostly Printed CNC firmware (leave a comment with your order if you want a different firmware of mine flashed), and comes with one terminal block for power.”

also, the mini does not support dual end stops per the website so I do not have them.

“If you want the dual endstop MPCNC Firmware you need the full rambo, not the mini.”

wiring is currently not using the wiring harness that came with the kit (to troubleshoot only), I have a one motor going to each of the axises as depicted in this picture (wired exactly like this) -

if I am having issues tomorrow I will upload pictures but I cannot at this point not at home.

Thanks for the info - have you loaded the Arduino drivers and Repetier-Host onto your PC? Screen shots of any errors from your PC will help as well. If you’re using a Mac, I don’t think I can be of further assistance… last time I used one was 2005.

This is the process I followed:

I’m assuming it installed the correct drivers since I installed the arduino software, I didn’t look at this yet.

I’m using windows, I can’t remember off the top of my head if it’s 7 or Vista (old laptop) I currently use it for my 3d printer as well.

When I used repeater host, it said it connected to the board via com3, then when I executed commands for it to move manually, it said it was in queue then finished the command. No error was thrown.

Pictures of your wiring when you get the chance. Have you ordered an LCD?

I received my screen yesterday. here are pictures of the wiring, using just the motors i received from V1 and the screen i ordered.

there is no display when i turn the board on but the second LED on the board will flash when the knob is turned on the screen.

Can’t move your motors until we’re sure that LCD is working properly. When power is applied you should see the Marlin and V1 Engineering logos. If you tried to use the Estlcam CNC controller, you may have inadvertantly flashed your mini-Rambo. You’ll need to reflash the board.

Hi, show us your wired up LCD, there are 4 ways it can be wired, 1 works , 1 shows blue lights and 2 show nothing.

after reading you post, i wired it up differently and now it works, and the motors work as well.

Seems there is issues from the computer to the board, looking at my device manager it sees the rambo but i believe its having issues with the drivers for it.

Is there any other suggestions than uninstalling and reinstalling the arduino software?

What version of windows is that?

windows 7


I have no idea, I am thinking there must be a special driver for a version of windows that old. You don’t have anything more recent?

Yup, if you google windows 7 Rambo driver there are several links.

I’ve got it working this morning, thank you for the support and helping me with these issues.

How did you do it for anyone in the future with this same issue?

these are the steps I did this morning.

Downloaded the correct driver for windows 7 (used this website but there was a lot of others

after following the instructions on that website, went back into repetier host to test the motors, did not work.

Uninstalled then reinstalled both the Arduino and repetier host software.

Found the com this was registered on (since im running a 3d printer and CNC setup on this computer)

Connected to that then everything worked as it should.

Perfect thank you