Possible Sources of X-Axis Error

I love my new MPCNC! It’s mostly working great. I’m using @Jeffeb3’s Pi image to drive it, Ultimaker Rambo board, dual endstops, and some 84oz/in steppers from Amazon. I’ve done some engraving with a v-carve bit, some light wood cutting, some vinyl cutting, and of course I’ve drawn some crowns.

My y-axis is perfectly accurate (to within my ability to measure), but my x-axis comes up consistently short ~0.6mm on 500mm. I should probably be happy with 0.12% error, but I’m wondering if I can get better. Drawing a 500mm x 500mm box with a ballpoint pen, my diagonals are equal (since I did my dual-endstop calibration), and both sides of the box in the x dimension measure the same ~499.4mm.

I’m trying to understand the possible sources of axis error, especially axis error that’s consistent on both x-axis rails. Here are my ideas. I’d love help listing out any others:

  • Belt too loose (check for consistent tension with the other axis)
  • Skipping steps (has a distinctive sound)
  • Bed surface very unlevel (Though I think an 0.6mm x-error would require a 24.5mm z-error across 500mm tan(acos(499.4mm/500mm))*499.4mm=24.5mm)
  • Both 16T pulleys slightly loose?
  • GT2 belts slightly out of tolerance?
Does anyone else have any ideas on what could cause an axis to have a consistent error across both rails in that axis?

Note: I apologize if this is a duplicate post. I’ve been wrestling with my posts disappearing (e.g. this topic somehow has no posts in it!). I’m tracking that issue here.

1 Like

Here are some pics!

does the pen mount has equal rigidity by x and y?
instead of the pen you may try to mount small laser pointer and mark point manually on paper

Here are a couple other thoughts:

  1. Look for any wobble in the middle assembly or the tool mount.
  2. Check that the middle assembly has contact on all of the bearings
  3. It may only be one of the two pulleys - though if you have dual end stops, this is less likely as the motors are independently driven.

I had/have the exact same issue, about .4mm short over 570mm. I’ll be following your progress. For now I just adjusted steps per mm and called it a day.

Good idea! I’ll Amazon a laser pointer

Oh cool yeah that is a good fallback.

I just ran a fine tipped pen in the air about 0.25mm over the top of the ruler.

I measured my own and it looks like I’m about a half mm off also, except mine is long.

This is close enough for me, but it does make me wonder what the cause could be. I made a test pattern to see if the lines were evenly spaced, just slightly large, or if there was a jump somewhere, or if it mattered if it switched directions (e.g. backlash or similar). For this I made a simple perl program but I think it might be cool to have a JavaScript version that’s publicly available. I might look into that…

ruler_500_x.gcode (88.2 KB)

1 Like

I tightened up my 16T pulleys and my results are a tad closer. I think I measure ~499.6mm now!

@Jamie I tried your ruler! Very smart to have it go both ways to find backlash. Thanks for sharing. It does appear that I have an ever-so slight backlash (see pic)

Do folks have a preferred process for tightening the set screw in the 16t pulleys? My process is to fully loosen the set screw that’s not on the flat side of the shaft, jiggle the shaft with pliers while tightening the set screw on the flat side of the shaft, fully tighten the set screw on the flat side of the shaft, tighten the set screw on the side of the shaft. Is there a better way?

Are you off on one axis or both? I’m noticing that all of my measuring tools measure slightly differently :slight_smile: I dont think I have anything that can measure sub millimeter accuracy over 500mm. But I am at least trying to get my X and Y consistent.

If it’s backlash, it might be something wiggling or rotating. Are your bearings all touching? Are your belts tight? Maybe some 0.6mm back and forth gcode would show you where it is.

That’s how I tighten the pulleys, and that should be fine. When people have had errors before, it was the set screw loose on the flat, riding back and forth.

1 Like

I have both axes a bit long. My belt tension might be high which in theory would give long axes if the belt stretches, but I am not jumping to conclusions. This is just one possibility. I also tried measuring the teeth on the belts. I’m not sure how precisely they’re made. In my case my measurement was rather clumsy and I couldn’t determine if there was an error or not. Using two of the little printed endstop blocks (facing the same direction) would make it easier to measure the belt.

Your backlash looks quite low to me. I don’t think you have anything loose.

I used a regex to make a y version of @Jamie’s ruler (attached).

Looks like I have a comparable amount of backlash in the Y dimension too. But in both cases, it’s only perceptible with a zoomed in photo. I think it’s something like 0.1mm. Probably not worth worrying about. Probably just as likely to be related to some backlash in the pen.

Measuring with calipers on 150mm spans of the ruler, it does seem like I have a continual small difference between the axes. Interestingly my X-Axis agrees with my calipers and my Y-Axis measures a little long when measuring 150mm spans with the calipers (I had previously been using a meter stick). So I think I’ll either slightly shorten my steps/mm (DEFAULT_AXIS_STEPS_PER_UNIT) in the Y-Axis by 0.12% or extend my steps/mm by 0.12% in the X-Axis, depending on whether I want to calibrate on my meter stick or my calipers :slight_smile:

Related question: Would folks expect $15 Amazon calipers to be a more accurate source of truth than a meter stick? (I know I’m splitting hairs here).

ruler_500_y-1.gcode (84.3 KB)

Sorry, I should have mentioned my other thread here that can do x or y or both that was motivated by these measurements

I found with a ruler I can line up a lot of marks, like a vernier scale, and get better resolution than my eyes can see.