Pre Release v1pi needs testing

Interesting. Running the gui on the pi that is also running cncjs and octoprint seems like a bad idea to me. But the rpi4 is pretty fast.

I’ve now reflashed the Pi with 2020-05-27-v1pi-hotspot, left it on the desk with tail -f /var/log/syslog and journalctl -f -u cncjs.service so I could see if anything was happening.

And of course no matter what I did, the dammed thing stayed up and running. Just to be clear, this is on the hot spot connected to my Macbook using the internal Macbook wifi. I do have another wifi dongle but ignored that for this test.

Created a couple of macro’s, still worked. Rats.

top looks OK, no swap on 2GB Pi 4. Given it’s running headless, I’d be surprised if 1GB isn’t more than enough. I run many linux boxes on VMWare with 1GB, wouldn’t run a Streetmap server on that but mail and small stuff is fine.

So, I’m going to check if there is a new version of v1p1, if so download that and benchtest that for 24 hours, if that works, I’ll attach it to the SKR MB and see if that was the cause of the outages.Something was killing cncjs but nothing so far. I’m suspecting the SKR motherboard and the connection failing now.



I’ll let you know when I post another one.

The requirements are pretty slim. It runs on my pi zero w, although it is noticeably slower.


Thanks, for some reason I thought there was a new version. I have no idea why :slight_smile:

I’ve connected it back to the MPCNC and am going to (finally, finally) put the end stops on and will have a look at it working then.

I would be doing more with your v1pi testing, but I went back to basics and made a mount for a digital caliper to measure stuff to find the issue with backlash.

It’s a never ending story :slight_smile:

1 Like

No worries. I am also trying to find some time to work on it, but my other responsibilities are winning.

Updated my v1pi yesterday…

Pi 3b+
TInyG control board
Shopfloor-tablet installed
Tinyweb-pendant installed

Aside from the pendant additions, v1Pi image is stock. No GUI, etc.

I’ve left it up and running, but mostly idle for ~24hrs.
I did run a few “air cut” jobs (movement only, router not mounted)
No issues noted.

Perhaps more relevant to the v1Pi CNCjs Pendants topic, I had all three interfaces (standard CNCjs, Tiny web, and Shopfloor Tablet) open in seperate tabs on my laptop and Tinyweb and Shopfloor-Tablet interfaces open on a tablet when running the “air cut” jobs. Top showed the node process using 15% or less of both cpu and memory during those cuts.


Excellent, Thanks Pete! :+1:


I think there is an issue (and I’m not sure where) between a Raspberry Pi 4 and the SKR V1.3 MB and cnc.js.

I left my v1pi hotspot powered up for a few days. I connected to cnc.js via web browser and played. with it. It was not connected to the SKR V1.3 MB. No issues.

I then connected it to the SKR V1.3 MB and tried to send down an output file from EstlCam. Bang. The cnc.js daemon crashed. I then restarted Octoprint and tried using that to do an air print and it worked fine.

Because everything is in the garage, I don’t have space to setup my laptop to monitor stuff easily and it was very late last night (circa 23:00) I didn’t have chance to check logs, but my suspicion is that there is a connection type problem. It might be the SKR Mb, it might be the Pi 4, it might be cnc.js, it might be all three. Since everybody else isn’t having the same problems, I’m tending to think it’s probably a comms type issue specific to me, could be a USB cable, could be a timing issue, the fact that the cnc.js daemon crashes but octoprint works fine, pushes me to comms.

Anyway, I’ll keep looking and I will find the issue as I would like to use cnc.js.


1 Like

Can we get a definitive answer as to the location of the cncjs log file? My linux skills are rusty.

running journalctl -u cncjs.service will show you the most recent log.

1 Like

Oh yeah, that was obvious :slight_smile:

How about the settings? I’d love to back up my custom commands and such. I’ll figure it out with enough time and motivation, but a hint would be great.

I grabbed the cncjs repo from github today, going to poke around and see about making a few things better for Marlin / Lowrider.

Noticed that Octo has a templating language that outputs G. Looking at CNCjs macros on git, it looks like there’s a similar thing going on, but I haven’t found any docs, nor how to load a macro or debug it.


/home/pi/.cncrc, I think. I tried putting a dummy file there in the image and it was replaced on the first runtime. Otherwise, I’d love to get some decent out of the box choices in there, like decent macros and default port and baud rate. Plus the plugins.

1 Like

The CNC.js interface on v1pi seemed somehow different from the one I got using git on an ubuntu-install. They were the same version. Don’t know if that’s because I’ve messed too much with the interface on my ubuntu box though…

I think the desktop is slightly different, but I couldn’t tell you how.