Printer not starting at Z Axis zero?

Hey guys,

Just got my MP3DP up and running and it appears that the printer is not starting at zero for the Z-axis. I leveled my bed to end stops 0,0,0 no problem. When I run a print, printer will auto home and then move to print, but it appears the Z axis is not getting back to Zero. I’m assuming this is a set-up field somewhere, but unsure if it is in my gcode program (Cura 2.1) or settings in Marlin. Any thoughts?



I’m not understanding the problem. A video or picture maybe?

Did you set your z endstop to the bed? You should not be using paper or a business card or whatever people keep using for some weird reason. z zero should be touching the surface of the bed. When you start your print it will move up all by itself to were it needs to be.

I did use paper shim for setting table. Always thought that was what you were suppose to do, at least was case on my previous printer.

I looked at gCode and it appears that layer 0 prints at 0.3mm which would match your explanation. Paper at 0.2mm (roughly?) plus 0.3mm start height would account for the gap that I’m seeing when starting a print. Thank you sir, I’ll reset table height and try again.

Thanks for the great design and hardware you sell as well! :slight_smile:



That is how some company suggest your level your bed, before you set your zero. Leads to a lot of confusion. The paper is supposed to act as a feeler gauge.

Glad this got you going. I hope to do some sort of getting started guide one of these days.

Reset platform and seems to do the trick, thank you for the help. It’s printing its first “real” part now.

Still have some fine tuning to do, but that is part of the adventure. Any recommendations on speeds? Seems to run a bit fast and slightly “jerky” (technical term…).

Getting started guide would be nice, but I’m sure you have a full plate, so completely understandable. You do great work my friend!

What are your settings now?

Cura settings are:

Speed Settings Screenshot

Firmware settings are unchanged, running RC8 on Arduino.

It may just be a perception issue when compared to my other printer…

On another note, the extruder fan does not seem to be turning on. LCD shows it turning, but no fan movement. Currently have fan connected to D9 port on Ramps.


I recommend these settings.

Printer is dialed in and working great, thank you for your help and advice!

Adjusted speed settings per your link, runs real smooth and consistent now.

Extruder fan was polarity issue with wires on D9, swapped to correct orientation and works perfectly.

Current speeds:

Thanks Again!


When I set my Bed stop I set the nozzle on the tape. Dragged it around the bed to be sure it was just touching the tape. Then I started a print, if the print was to close or far from the bed then I stopped the print. I would then adjust the beds end stop screw 1/4 till I got a good first layer. Haven’t had to mess with at all after that.

Your speeds are kind of all over the place. Large changes in speed will cause globs of material from the pressure difference. Stick with a 50% speed first layer, 10% outer wall and top layer reduction, possibly a 10% increase for infill.

50 is pretty fast, are you getting bad ringing? Anything above 40 for me looks pretty bad.