Question on stepper torque

Hi, I’ve been doing some cutting with my MPCNC machine and reasonable success with soft materials, working up to something harder.

I’ve been testing some different CAM packages and in testing with MeshCAM I found an issue with losing steps on the Z axis. MeshCAM does a LOT of Z axis moves during the milling operations.

I’ve tested with the torture test gcode for the Z Axis and it does appear that I lose some steps. I’ve checked free movement of the Z Axis and loosened a couple of bolts a bit, and pushed the current limit back up towards .6V ref from .49V. But there is still some lost steps especially when I try to machine something more substantial then foam. It’s not much but it is enough to be a problem if I was machining a real part.

I’ve made sure the threaded rod isn’t rubbing, things seem to move pretty easy. X and Y are fine so far, just the Z is problematic. Didn’t see this until I added the DeWalt router.

I had some older steppers that I used in the initial build, but going back and looking at the specs for those steppers and the ones in the link from the parts page here it appears that the holding torque for my steppers is 47 oz-in and the ones on Amazon are 84 oz-in. The current rating on my steppers is .8 Amp per winding.

So I’m thinking that I probably need to get the beefier steppers and change out at least the Z axis stepper to correct the problem, unless anyone has other suggestions. I’ve pretty much exhausted addressing the usual suspects.


Since you are using smaller steppers the first thing to try is a z-axis firmware edit, turn the top speed down just a bit and turn down the acceleration even more, that should help. slower acceleration should fix the problems.

I’ll crank it down more. I have it pretty slow already. Have a new stepper coming on Tuesday that should resolve it.

Right now still testing, and working up to cutting something real. But the new center design is really solid and working very well.

We’ve made some decorations / props for an upcoming performance. We have a circuit of assisted living facilities that we perform music at each month, and one of them wanted a special under the sea theme. So in addition to doing a lot of sea and beach related songs we made some props using the MPCNC and my wife is painting and decorating them. Came out really great.


I got the new stepper. Had to work out the wiring since it was different than the other steppers I’ve worked with before. Turned out the supplier had a batch that were wired incorrectly. Not a huge deal but took some time to troubleshoot and correct.

I found that the screws on the Z Axis motor were a bit loose. I was pretty sure that I had them tight when I put things together but I may have missed that final tighten. I added lock washers and will keep an eye on it.

I’m using a higher current driver for the Z Axis so I can push the new stepper closer to it’s max. Right now the stepper is not even getting warm after a quick series of the torture tests. Or with the wood test I ran below.

I ran the Z Axis test about 10 times in a row and each time it returned to the exact same Z position. So between tightening up the Z Axis stepper screws and the beefier stepper that is a huge improvement.

So I got brave and decided to try milling a piece of 3/4" board I had laying around. Got about 1/2 down all going well and then got a glitch that tripped an alarm. It could be from the router but I didn’t have any such issues in all my earlier testing, but I was running the router at minimum speed for the foam tests, and I stepped it up to max for the wood test. Right up until it stopped the cut looks very good. But I think that it might be loosing steps when milling the harder wood.

The tip of the tool was at about -10mm into the stock when the alarm hit. I issued a G0 Z5 which should have taken it to 5mm about the surface, but it appeared that it was about 5 or maybe even 10mm below the surface, but I don’t recall right now. It was below the surface in any case.

I had gotten ambitious and boosted the Z max and acceleration values and had run the torture test with those values we the excellent results as noted above. But they may be too ambitious for actually cutting something harder.

So tomorrow I’ll back the Z axis settings back down and try another pass to see I can get all the way though the wood milling and not loose any steps.

I still have some room to increase the current on the stepper driver so I may need to do that as well.

I believe that the coupler is as tight as I can get it without breaking anything, but I guess I should check that as well to make sure that I’m not getting any slippage with the coupler.

Any other suggestions would be welcomed.


max speed for the z axis with 32nd stepping and a 5/16 rod is 8.819mm/s this number is set by arduino and its 40k commands/sec, acceleration is the only thing you should mess with unless you need to lower the speed for some reason.


I probably got a little too aggressive on boosting the max speed. Although it should be within that range. I might have pushed the acceleration a little too much. So I’ll back it off in the morning when it’s not storming and try again.


Much better with this morning’s test. I milled a the same small part out of some moderately hard wood. No false limit alarm and I had dropped the Z axis max speed and acceleration back to what I had with my old stepper. I have some room to push the current limit up on the Z Axis and since the motor is still staying quite cool compared to the old stepper I think that I’ll push it up to gain some more torque, then I’ll repeat my test taking the Z speed and acceleration back up at least a little bit.

I thought that I might have an issue with the X and Y but double checked the gcode and it was just that the gcode was slightly offset from 0,0 to allow for adding support tabs to the piece. So other than the fact that I could probably use more torque on the X and Y it’s looking pretty good at the moment.

BTW in one of the posts here you had posted the code for the Z torture test. A couple of the lines of gcode are missing the “F” for the feed rate. With GRBL at least this caused some interesting moments as the tool was trying to go to -3522. Here’s one of the lines from the post:
G1 Z-3 522 should be G1 Z-3 F522 There is another further down.

Maybe this works OK with the RAMPS Marlin firmware? But with GRBL it ignores the space and treats it as a relative move to -3522. Just thought I’d mention it.

Running a test with .4mm step down but leaving my slower Z Axis firmware configuration for this one.


I was running at a very slow Z rate, so I was able to kick it up to 8 mm/sec and still seems to be working quite well.

I have just a little bit of deflection where I see that a couple of bearings are just shy of touching the horizontal rails. I tried to tighten things up more but then I was losing steps big time in the horizontal direction when using a step down of .4mm and a moderate speed for X/Y. So I loosened it up again for now. The end result doesn’t appear to be impacted by what I was seeing, but it shouldn’t have that deflection. I may need to wait for the rest of my new steppers to arrive before I try tightening it up again so I have more drive power.

But the good news is that backing off the tension a bit again and I was back to working quite well. And Z is much peppier now:)