Rambo not turning on

Hi all,

I have purchased the kit with the full Rambo, and was trying to manually move it via the Repetier software. The axis did’t move when I tried, so I unplugged the Rambo and plugged it back in. However, the Rambo didn’t turn back on. I have checked everything, the connections and outlet, and nothing seems out of the ordinary. Is there a way to get it back on?

Edit: I just checked the voltage of the connector to the Rambo, and it was correct. This leads me to believe that it is a problem with the Rambo. I know about this other topic: https://www.v1engineering.com/forum/topic/rambo-does-not-power-up/ however, I have tried the solution and it sadly did not work for me. Maybe a fuse is out?

Thanks in advance!

You can check the fuses easily enough. They should read close to zero ohms on the multimeter.

1 Like


Tested both small fuses and found that one didn’t give a read (circled in red).


(sorry for the link, you will have to copy and paste the URL to view the image)

That is linked to your hard drive. It won’t work no matter what.

Whoops sorry about that. I didnt see the attachment option at the bottom

Here it is:


Edit: I ordered a 10 pack off of amazon once I switched the fuses and a light came on, confirming my suspicions.

Thanks your all your help!

I have fuses available or you can get them from digikey/mouser. Maybe upload a picture of your wiring so we can see what caused to pop.