RAMPS 510 - No Z movement

Probably something I’ve done wrong but I need help…

I’ve just picked up my stalled Primo build again today and replaced the 414 software with the latest 510 (https://github.com/V1EngineeringInc/MarlinBuilder/releases/download/510/V1CNC_Ramps_Dual-

And now I have no Z movement from my LCD… I’ve checked the driver by swapping it to the Y and I’ve checked the stepper by swapping it over to the X driver and all is good but regardless of what I do I have nothing on the Z…

Like I said something simple I’ve missed probably…

Anyone help?

Cheers, Jason

1 Like

Strange. So version 414 would move the Z axis? Did you check this just before you updated the firmware? So to be clear, when you tested the Z stepper by swapping it to X, you made that swap at the control board so that you tested the wire and the stepper? Also this is not an update from an old version of the MPCNC that used threaded rod instead of a lead screw is it?

The next thing I would do is to reinstall version 414 and see if that fixes the problem. If it does, then you can use a difference tool to look at the differences in configuration.h and configuration_adv.h for both versions. There is still access to some of the older versions of the firmware. @vicious1 mentioned them when working with another forum post, but I don’t remember where they were.

If it doesn’t fix the problem, you probably have an issue with the board…probably a pin on the MEGA board, but that is only a guess.


Sharing a few pics might help us see something wrong too.

1 Like

Do you have anything plugged into the Z min or max endstop pins?

1 Like

Sorry my original post was lacking a few details :slight_smile:

With 414 all axis worked fine - but that was probably 6-8 months ago when the build stalled, since then the Mega and RAMPS boards have physically moved mounting position but they are the same boards, same wiring etc.

When I say I swapped the Z motor to the X drive, yes it was changed at the RAMPS board so it test the wiring and the motor.

I’ve only ever used a lead screw on this build.

I like you idea of rolling it back to 414 to confirm it works - or not - I should have the old 414 build on my PC still.

I also have another MEGA board too that I could swap over to and test that too.

Good thinking, will take some soon.

No I don’t have any of my endstops wired up yet, only a Z probe but I’ve also tried it with and without the probe hooked up and both the same…

Thanks to all those that helped - first thing I did tonight was swap out my MEGA, found my spare, flashed 510 on to it and low and behold it works perfectly! YAY

Now on to the rest of the build and get this thing finished…!

Thanks again all and especially you Ryan this thing is so cool!

1 Like

I also had no Z movement. The LCD only moves X,Y in one direction. I manual moved Z up and the the LCD will move in one direction only for all axis…bad potentimeter?

You should probably open another thread.

But try connecting a computer and controlling it that way to see if it is the screen or the board.