Repetier slower than Estlcam


Ive had my mpcnc for around a year now. And ive not used it for a month or so.
Now im back, and ive had to reinstall all my software on my windows laptop.

The last time its all been working great, but this time i have a problem with speeds.
All settings have been copy pasted from Ryan’s guides, and they were when i started the first time aswell.

When i put a basic drawing into estlcam, i get a working time of around 2 mins. When i import the gcode from estlcam into repetier, i get a worktime of 1,5 hours. When i play the program, everything is going extremely slow, like it would actually take 1,5hours.

My feedrate in the manual control tab is 100%, so basically whatever estlcam settings are in the gcode.
But its still going to take 1,5 hours. If i just manually move it in repetier, at 100% it moves fast, like it should.

I just cant find the solution or setting to make repetier read a file like it should.

Oh, and ive tried Estlcam 10 and Estlcam 11. With the same slow speeds. So i would expect it to be repetier that is making my problems.

This is wierd.
If i export .gcode from estlcam i get 1.5hous in repetier, if i export as .nc, i get the 2 mins. And everything looks fine when i play that…

You’re off by about a factor of 60. EstlCAM probably thinks you want to set the speeds in mm/s, but Marlin uses mm/min (for some stupid reason). The speeds end up in the F value of the G1 commands. They should be 600 for 10mm/s. There’s probably a drop down in the EstlCAM settings for Marlin.

On this screen, or similar:

1 Like