SD Card Problems

As the title says, I’m having some SD card problems. I’m using the Ramps 1.4 setup with LCD controller and stock cables as ordered from Vicious Circle here. The firmware is the Marlin build for the Lowrider downloaded a couple days ago from here on this site. I’m familiar with how the ‘Print from SD Card’ option is supposed to work - use it all the time with my 3D printer.

What’s happening is this. I insert the SD card into the LCD screen and the initial screen says 'Card Inserted". Then push the button to go into the menu and it says “No SD Card” - and when I go into the “No SD Card” of course there are no files displayed.

I’ve tried both a 2gb and a 8gb SD card - both formatted for FAT32 - and I’ve tried file extensions of .gcode and .gc and .nc if that matters at all.

I’ve seen comments from people that long cables cause problems, but I’m using stock length. I’ve also seen older comments about FAT32 not being supported back in 2013 or so, but as far as I can figure it’s a supported format now.

Sort of out of ideas to try at the moment - any thoughts out there? Can anyone confirm their SD card format parameters, size, and file extensions just so I know I’m using the right specs for this?


1 Like

2 things to try. I have the same problem with a few of my SD cards. First thing, once you get it to say card inserted, reboot the ramps board. If that doesn’t work try swapping the cables maybe one of them is kind of bad.

Yep - it was a cable crimping problem. The clue was it would recognize the SD card was inserted, but then wouldn’t read any data from the card - so one or more of the connections was being interrupted between the LCD module and the Arduino.