Setting X_MAX_POS and Y_MAX_POS in firmware

I did this a few months ago & it worked, but now that I have lengthened my MPCNC by 4" in the Y & 2" in the X, I wanted to change it. For some reason this is not working. Maybe there was something else I needed to change. Here is what I changed in the firmware that I downloaded from here last August. I see there is a newer firmware dated 11/25/15 & these limits are set to 1000. Maybe I should try that & leave them set to 1000?

// Travel limits after homing (units are in mm)
#define X_MAX_POS 570
#define X_MIN_POS 0
#define Y_MAX_POS 820
#define Y_MIN_POS 0
#define Z_MAX_POS 152
#define Z_MIN_POS 0

I had changed this to 520 & 720 for the X & Y last time & it will not go past 520 or 720. It obviously worked before since it stops at 520 & 720 & the change I just made to the endstops is working now, so I know it uploaded the revised firmware. Anyone have a clue as to what I am doing wrong?

I also set the endstop inverting to false for the X & Y axis, since I wired these the same way my 3d printer was wired.

// The pullups are needed if you directly connect a mechanical endswitch between the signal and ground pins.
const bool X_MIN_ENDSTOP_INVERTING = false; // set to true to invert the logic of the endstop.
const bool Y_MIN_ENDSTOP_INVERTING = false; // set to true to invert the logic of the endstop.

Thanks for any help,

I went ahead & tried the 11/25/15 firmware. I got an error with the firmware 1st time I tried it which was something about max temperature. I commented out the lines related to the heat bed & it seemed to upload ok. It changes the X_MAX_POS correctly, but the Y_MAX_POS seems to stay at 720 since it will not move past this number.

Did you change this in repetier as well? Or whatever control software you are using.

That was my problem. Thanks for pointing that out. Having this problem did lead me to make another change in the Configuration.h file.
I uncommented the following line so I could make minor adjustments to the firmware to test something without writing all the firmware:


Thanks again for spotting my problem.