starting job: G92 doesn't work in Repetier so I disconnect/reconnect

I typically start jobs by moving the tool to the top of the workpiece (as shown in 360.png below). The issue is, G92 doesn’t work in Repetier Host. My solution: disconnect and reconnect in Repetier. This sets the axes at X0 Y0 Z0. This seems to work most of the time. However, sometimes after the disconnect/reconnect, the gantry drops. In the mpcnc.jpg below, the shadow shows how the mill dropped from the start position after disconnecting.

How can I get G92 to work? Or, how can I prevent gantry from dropping?

Other info: RAMBO board (not sure which version- how would I find out? bought from V1 ~1.5 years ago) seems to be running Marlin 1.0, Repetier 2.1.6

Grateful for your help. Thanks!



You’re doing ‘G92 X0 Y0 Z0’?

I remember problems with this on older firmware. Updating to a newer version of the firmware would solve it. I haven’t heard of the problem in a while.

1 Like

Exactly, I do G92 X0 Y0 Z0, but nothing happens. Is there a good reference/link for how to update firmware?


EDIT: I’ll give this page a shot:

Yep, that’s it.

1 Like

I reinstalled the firmware. It seemed to change the behavior, but not fix it. Now if I run G92 X0 Y0 Z0, it seems to partly accept it. For example, if I turn on the machine the x axis is at 0. If I move to X50 and then do G92 X0, the log shows X:0.00 but the manual control still shows X at 50. However, if I try to move -10, it moves +40 and then shows x40 on the manual control?

I’m stumped. Should I try to do the firmware again? I am running dual end-stops in case that contributes. Should I try a different controller, maybe cncjs (was going to try Octoprint but it needs python 2.7?)

edit: I installed the MPCNC_Rambo_T8_16T_LCD_DualEndstop zip from here:

edit2: just noticed I was using arduino 1.8.5 will update and try again

edit 3: now G92 behavior same as initial situation

Repetier does not recognize the G92 command as far as I know.

1 Like

Goodbye repetier then. Thanks for your help Jeff and Ryan. Btw Jeff, I’ve read so many of your posts, I always read your username a Jefe (ie spanish pronunciation). Anywho thanks and I think I’ll try cncjs and report back.

update: WE ARE BACK IN BUSINESS! The cncjs desktop app did the trick. Thanks gents!

It happens a lot. Ryan sometimes calls me Heffe too. But my last name starts with Eb, and back in the aol days, I tried jeffeb, and then that got full of spam so I went to jeffeb2 and then that got full of spam so I switched to jeffeb3, then spam filters were invented.

Shhhh, Heffe, you don’t need to lie we are all trusted friends here. Your identity is safe with us El Jefe de CNC!