Stupid Idea

you Know what? I think this is the most stupid project I have ever done . it is like a toy and not a CNC machine and programing the Arduino is just another stupid attempt. when you get one thing going another goes wrong. I’m throwing this in the trash bin and get into the real world of CNC and stich to Mac3. and Fusion 360. and a real CNC machine. tired of screwing around and spending time printing the flimsy parts and get a disappointing results. first of all when it makes a move, it shakes. secondly it is not accurate. bye, bye MPC . I’m done with you.

Sorry to hear you feel that way. Please let me know if you feel I/we have failed to help you.

With a few thousand sold I feel we had most of the instructions clear and concise at this point.


Where do you feel I have failed? This is the worst feedback by far I have received in more than two years in business and I take this very seriously. Did you buy the kit from me, I will glady refund you?

Honestly at this point I don’t think I have ever had a even slightly negative review, and I am very interested in your detailed feedback.

I regret What I have posted and I apologize. I was very frustrated by losing 1 board and the second board I purchased went koo koo after I asked how to make the machine run by the computer instead if The LCD only and was told to download the Adruino which I did and got it working but the next time I turned on the board my LCD. screen was just blank. couldn’t get the Marlin showing nor could control anything with it. and didn’t know what to do. but today I finally figured it and reprogramed the board and now is back to where it was. I am so happy but very sorry for being impolite and inpatient. But I still am getting jilts in the movement when I run the program. lines are not straight. but I have asked for help and waiting to hear from someone at the forum. OH, I am going to build the Low rider Next. Very excited.

The forum posts previous to this have gotten lost do to my Server issues this morning but we have asked for some pictures to try and spot obvious errors in the build.

I shall do that very soon thank you.

well this is my built which is not final but when I jog the axis everything is smooth, but when I run a program then I get a strange jerks in X - Y travel. seems like if there are miss steps in travel. I tried re alinement and readjustment of bets and screws but nothing helps. the bed is designed to cut 2ft. by 3ft. stock. Could that be the reason or is it in the program. has anyone experienced this?
I also can post a Video of actual movements drawing the Vicious Logo if it helps.

It is jerky when running My logo file, or one you made? Make sure to test with mine so we know the gcode is correct. A recent issue that was found was a power supply was bad and the light on it would blink and the machine would move in sync with the blinking light. Have a look at that.

Thank you Ryan: I will check the power supply and let you know soon. Oh: I did use your Logo file and the G code should be right. is your logo suppose to be deformed lines maybe? and I’m just imagining things?

Lets see a picture of your drawing.

I can say you want the mount as low to the surface as you can get. The way you show it in the picture is no good. Imagine trying to sign your name holding the pen so far up. That and the surface you are writing on has a huge effect, and a ball point pen is not ideal, a fine point sharpie is best.

You can see in the video I made the ball point pen is being used on a full drawing pad to make it work. (this was before the new pen mount but the theory is the same).

Can’t tell if it’s the power supply since it has no light on it. I bought it from you, I think it is working ok since when jogging everything is smooth could it be the settings which effects the movement? maybe it is moving too fast? or might even be the conduit since EMT. doesn’t have a smooth surface anyway and effects the minor movements. what do you think.

Picture of your drawing, preferably on notepad not paper on wood. At this point I have no idea if there is a problem, your descriptions are subjective.

The power supply thing is very obvious, it would literally stop moving and the move on and off about every 2 seconds.

Thank you Ryan for your time and help. I shall check everything you mentioned and hopefully everything shall be right. thanks again, :slight_smile: I may have better luck with the low rider since I am almost done printing the last part. and I have to order the rest of the parts and electronics from you. Whish me luck. :slight_smile:

Ok: this is the result after I retried on a not pad and all. so it seems like if I have an electronic Problem to me. Don’t you think so Ryan?

That is not an electronics problem in any way.

Did you lower the pen in the mount like I suggested earlier?

I would say all of your tension bolts are way too tight. Looking at the picture from earlier I can see the roller bolts are super tight, The instructions say to leave these loose and only tighten if you have issues. On mine, I just barely have the threads showing through the nuts, on yours I can see like three more turns worth of threads.

So any longer bolt that has plastic on both sides is a tension bolt, loosen them all. Any short bolt that has plastic on one side and just a bearing and nut on the other is not a tension bolt. If that isn’t clear look through the instructions again they all have a bold sentence that says whether you should snug it down or not.

thank you again Ryan: I know which are the tension bolts, and I already tried that but not loos as you say. I will give it a go and let you know. Thank you again, you are a Gentleman for helping me out.
:slight_smile: funny thing is, that I never thought I’ll have to ask for help on something like this since I studied mechanical engineering when I was much younger. talk to you later.

Just fixed the problem with jerks, yeah::::slight_smile:
found one stepper motor mount loos. Everything is perfect now after I tightened the screws on the mount.
want to thank you for all the effort to help fix my problem.

Glad it’s working