Which Firmware???

So, in trying to troubleshoot my heated bed and extruder issues I’ve noticed that the firmware on my miniRambo is the bugfix 2.2x and not the MP3DP_MRambo. Should I reflash my miniRambo? I did buy it from Ryan but I’m guessing he may have just put the wrong version on there (or I didn’t specify) or is it even an issue?? Thanks again!!

I would recommend flashing it yourself, even if it did come from Ryan. Knowing which firmware and what configuration is on the printer will be really valuable, and make it easier to change things in 6 months, when you feel you need to. The MPCNC isn’t as necessary, but for a printer, there are a lot of things that you might want to change, and you can’t get the source from the controller, so you have to keep it when you flash it, and to do that, you have to flash it.

But, the MPCNC/Low Rider firmware does not have the right setup on the temperature sensors, so that might be your problem. Probably, the one you think is plugged in is actually the dummy, and the other one is N/A. Does that sound right?

I second Jeffeb3’s response on both the knowing the firmware details and as a probable cause for your thermistor issue. FWIW, Ryan’s shop lists the miniRambo as coming with the MPCNC variant by default unless you want the MP3DP version.

[attachment file=89007]


Thanks guys!! I saw that info on the link about the MiniRambo being flashed with MPCNC firmware after I asked my silly question! I’ll be flashing the MP3DP firmware in a bit and I’ll let you know how it goes. This thing makes the LR2 seem like a color by numbers picture… lol. SOOOooo much more to do with the printer.

There’s at least 2x going on, and the motion and extrusion interferes with each other, so tuning the machine is a pretty steep learning curve.

The difficulty with CNC is in the CAM. Once you get the printer working, you can usually download a print from TV, slice it with the same settings you use all the time (which is one click) and send it to the printer to print. Compare that with CAM for the low rider, which is quite a lot of thinking in software, sometimes some test cuts/tuning, then the workpiece setup, and you have to be present the whole time while it cuts.

They have different challenges and benefits. The 3D printer makes really detailed things, in a mostly clean way, with complex geometries. But the Low Rider can make huge pieces of art or even furniture out of materials people actually like (sorry, but people hate plastic).

Combine them, and add in some CAD skills, and you’re really making things now. The MP3DP or Low Rider are sort of the culmination of those efforts. I had a 3D printer, I made a MPCNC (with no flat parts needed). I made an MP3DP, and then printed and cut parts for the Low Rider. I would love to actually make my own machine in this vein. Something like a lathe or bandsaw would be neat (although I’m pretty terrified of making either of those machines myself). Even something like a monitor stand, made with 3D printed parts, and some plywood structure to make it larger would be a good project with these machines.

Whelp, you guys were right!! Flashing the firmware worked! Now my extruder and heated bed are working and the fans are working as well! That was an easy fix! Thank again!

Edit: It seems now that I did that firmware upload I now have to over-write it with the Dual Endstop firmware? Or is that just for the LR2?

Edit #2: I’m so lost!! Now I’m not sure what I’m doing. There are different files on GitHub and I’m not sure which one to flash: MP3DP_MRAMBO_16T_aero or 1.1.x??

I have flashed MP3DP_MRAMBO_16T_aero to my miniRambo and editing the 2 settings I needed to change for my MK8 extruder. Now I just need to figure out the Homing processes and the X,Y,Z Endstop deal. lol.

I completely understand what you are saying Jeff - making stuff with a combination of machines is pretty darn awesome!

It definitely seems like the “pain” in the MP3DP is mostly upfront, while with the LR2 it’s more spread-out but non-stop. Lol.

I’m getting there - I’m just happy that it is moving and heating now… lol.

Yep. There’s no dual endstop on the MP3DP.

Make sure your motors are moving the right way, and send an M119 to test the endstop switches, and you can hold them down with your finger with an M119 and make sure they are wired right. Then hit home, and if for some reason it homes the wrong direction, then hit that reset button. If that all checks out, then there might be some adjusting of some set screws, but the homing should be good.

The X,Y, and Z should move 10mm-ish when you ask for 10mm. Their step counts are nice round numbers, so it would only be wrong if you had a 50 when you needed 100, but Ryan’s firmware should have those right. Then on to tuning the extruder, which entire books have been written about, I’m sure.

I’ve had printers for over three years, and I’ve only recently felt like I can have confidence printing something (on either printer) and it will come out fine. I have been through about 15 spools so far. I don’t print very much, really. I guess I’m saying the pain ebs and flows :D.

Thanks for the info Jeff!! I’ll be putting this to work tonight and see what I can do! I’m sure I’ll have more questions soon. lol.

Jeffe - your advice worked! I got it all set up and homing properly now with the endstops working great!

My only problem now is that no matter which of the 2 fans (either the extruder fan or the part cooling fan - same fan setup you have on yours) I connect to the Fan2 port - neither of them will come on when I try to send them a command via RepetierHost. I dunno if I’m doing something wrong in Repetier or if I need to modify the firmware for the second fan. In Repetier, I went into Config/Printer Settings/Extruder and told it I had 2 fans (not sure if this is correct or not). In poking around the firmware it talks about the different Extruder Fans and only one of them is enabled and it is connected to Pin 6. I looked at the schematics for the miniRambo and it appears that Pin6 is for Fan1 and Pin8 is for Fan0 (this is a little confusing because the board is labeled as Fan1 and Fan2. You would think that Fan0 in the schematic is Fan1 on the board and Fan1 in the schematic is Fan2, but if what I’m seeing is correct, it’s the other way around. Any ideas??? I’ve attached a couple of pics of what I am looking at…


This is in my Configuration_adv.h for the einsy, which isn’t exactly like the rambo:


  • Extruder cooling fans
  • Extruder auto fans automatically turn on when their extruders’
  • temperatures go above EXTRUDER_AUTO_FAN_TEMPERATURE.
  • Your board’s pins file specifies the recommended pins. Override those here
  • or set to -1 to disable completely.
  • Multiple extruders can be assigned to the same pin in which case
  • the fan will turn on when any selected extruder is above the threshold.
    #define E0_AUTO_FAN_PIN 6
    #define E1_AUTO_FAN_PIN -1
    #define E2_AUTO_FAN_PIN -1
    #define E3_AUTO_FAN_PIN -1
    #define E4_AUTO_FAN_PIN -1
    #define E5_AUTO_FAN_PIN -1
    #define CHAMBER_AUTO_FAN_PIN -1
    #define EXTRUDER_AUTO_FAN_SPEED 255 // == full speed

The E0_AUTO_FAN_PIN Sets one of the pins to only come on when the extruder is warm.

I brute forced mine and just connected the extruder fan to +12V heated bed power input. Whenever I have power to the heated bed power input (via relay controlled by the RaspPi/Octoprint), the extruder fan is on and I only print with the heated bed on.

Hmmm, I wonder if the Fan2 output on the miniRambo is like that - only powers up when the extruder is at temperature. If so, that explains what’s going on. If not, then I might do what BT did and just brute force it.

Thanks again for the suggestions!!

That’s how I used to do it. These new boards have two fan outputs though, so I might as well use them

Jeff, take a look for that line in CONFIGURATION_adv.h.

I have that same line with the same settings except the:
is set to 80 on mine. If you are using both fans on yours then I doubt that is the problem (but I could be wrong).

I tried it again just a little while ago and let the extruder and the bed both come up to temp and the fan in Fan2 still didn’t come on. I’m wondering if the board itself has an issue on that output? Repetier host seems to think it’s sending the proper command.

Another interesting thing is the LCD screen (which I also have) doesn’t want to control that fan either - it only shows 1 fan in the Temperature menu. It’s gotta be something simple that I’m missing.

The extruder fan needs to be on anytime the hot end is hot. The part fan (pointing at the prints) needs to come on when you select it in the LED.

I got it working!! Who knew that DC fans could only be plugged into one of these boards in 1 direction (I just figured they would spin backwards if plugged in wrong but that’s not the case). So now the Fan controlled in Repetier or the LCD is the Part fan and the Extruder fan is coming on when the extruder is on and then stays on until it cools off.

Seems like now I need to start a new thread for a different question… lol.