X and Y movement issues

Been running the machine for about 6 months now relatively smoothly. Relocated the machine, and upon trying to run on Repetier again having serious problems with movement in the X and Y direction. The Z works perfectly, but when trying to move in the X or Y, motors experience severe shaking and do not move properly. After taking the belts off, I can see that they do not spin properly in the direction they are supposed to, and instead just kind of shake back and forth. It worked temporarily in the Y direction before going back to the shaking. While temporarily working, I tried flipping the ports and the X direction still had problems on the “working” driver. Wiring is good as I have ran the machine many times before. I was thinking it was a firmware problem and reflashed Marlin and it changed absolutely nothing. All hardware is from the Vicious site, with Marlin firmware.

Any thoughts or insight on this problem would be greatly appreciated.


A wire came loose somewhere.
Only one of the two coils is powered, sounds like.