X axis jitter

Hi everyone,
I’m having an issue with x axis jittering, seems like I noticed it after test milling mdf and foam. My rails are straight and smooth, belts tight. Tried loosening the tension bolts and also tightening them. Any suggestions what else to check?

Speeds, software, gcode. More information would make this easier, I didn’t see anything in the video.

Try the questions in the sticky and we should be able to get this sorted out quickly.

I’m running the vicious firmware. I didn’t buy the parts here, but I did use the links in the parts list. Using a LCD on the ramps board, and moving axis via the ramps LCD. Also tried moving via repetier host and also ran some gcode with tool in air and seeing same thing. Gcode feed rate set at 15mm/s.

Only modification is that I’m using a metal coupler instead of the printed one. No mechanical endstops, I do have manual endstops to help with bit changing. Yusung a pc windows 7.

I’m having a hard time capturing on video what’s it’s doing, it like there’s oscillation when moving on the x axis.


I’m assuming your not talking about the pauses between commands, your talking about the sort of sticking. Is your table wobbly? It’s not skipping steps, so there must be something that’s flexing. I had something like that until I tightened the belt. You can also put your hand on the motor, and feel it jittering. If it just one of them, then you’ve narrowed it down a lot.

You can try sending gcode directly at different speeds. Something like:

G00 X50 F900
G00 X0

G00 X50 F1500
G00 X0

The F numbers are speeds in mm/min. You can put that in a file and load it or there is a console in repetier, isn’t there?

Hi Jeff,
I took it apart, re squared and also cleaned foam off my bearings that I was cutting. Seems that it helped.