Yet another not-correct-size question


So I ran this gcode yesterday:
Bitsholder2.gcode (222.3 KB)

flyfisher post processor
V1 Marlin

The final part was expected to be 303x80mm but it came out as ~296x73mm. So it is -7mm in each direction. I used a 3.175mm end mill. Feed rate 480mm/min.

Directly after this job I just made the machine my basic calibration test.
G0 X200 = 200mm spot on
G0 Y200 = 200mm spot on

So that works well… And I have not found anything that is loose (not even a grub screw)…

I wonder what caused it to be cut so much smaller than expected? Missed steps? The piece came out square.

/ Oskar

Are the holes spaced evenly but only the outside profile is off?

Did you cut inside instead of outside the line?


The issue is in your CAM setup. Taking a look at the code in a gcode simulator and looking at the square I found the following min/max values when drawing the square:



This is the path the bit traces, so it cuts half a bit width inside these coordinates making the object a full bit width smaller than these coordinates. So based on the g-code, your object should have been 296.651mm x 73.65.

My educated guess is that most of the issue is as Tom suggested and you are cutting inside the line rather than outside. In Fusion 360, in the tab where you define the cut path, you can click on the red arrow to change whether the bit cuts on the inside rather than the outside.

But there is still some discrepancy. There are other settings that impact what is cut. For example, if you define the bit as the wrong width, or you have set “Stock to Leave” to some value. What I suggest is that you author a contour cut of just a rectangle and take a look at the g-code. When you have all the settings “right” the path cut should be just a bit width larger than the rectangle you authored.

If you establish the center of your stock as the job origin, you can paste your code into this g-code simulator, and it will give you the min and max values. Those values should be the author size plus the bit width when you have all the settings “right.”


Aaaah of course!! That makes perfect sense. I looked for the little arrow that tells if it should cut inside or outside and it was teeny tiny at one of the corners.

Thank you SO much. Now I know what more to look out for :slight_smile:

1 Like