Z axis dropping and dragging

Hey all,
Another issue I am running into. I have a lowrider2 3’x6’ build. I set zero on all axis’s. When I begin a cut the Z axis likes to plunge into the start point, it then picks up and drags across the material to make a cut. I can get the Z axis to stay high enough to make cuts without dragging however it does not reach the set cut depth. I have also tried to start the cuts from the opposite side of X axis but the machine does the same thing. Also finding out if I zero all axis’s and shut off the machine, only one side of the machine drops down.
You can see in the pictures the plunge holes and the dragging across. I will try to get a video of the z axis dropping when turned off.

1 Like

What do you use to send your g-code to the control board? Can you attach the g-code file to a post so we can take a look? Is the depth okay for the rest of the cut, or are you losing steps?

I am using ESTLcam for the design then using Repetier-host to send the code to the machine.

A drop can be for a number of reasons, but we need some info to sort it out. I’m concerned that the g-code did not lift the router to a clearance height. That is why I wanted to see the g-code. You can use the button above to directly attach your g-code file to a postUploadIcon .

Lost steps is a common issue that has several causes, so we need you to determine if the cuts in the wood are at the depth you specified in EstlCAM.

So I just tried to run a cut. As soon as I turned on the router the router dropped instantly. It’s almost as if the steppers are not engaging or not engaged at all

Gcode.gcode (42.6 KB)
Here is my Gcode

So steppers don’t engage until the first movement. I don’t have a LowRider, but on forum posts it is common to need to rest the Z axis on blocks to avoid the Z axis from descending when the steppers are not engaged.

Sorry for the not so smart questions. So set zero on all axis, place blocks under x axis rails, turn on machine, remove blocks, start cut?

Assuming your router does not descend when the router is not running so you can place the router at the (0,0,0) point when the router is not running, I would put the following at the beginning of the g-code file:

G0 Z1  ; Lift the router slightly to engage the stepper
M0 Turn router on and click to continue

I’m not a LowRider owner, so there may be better ways. Any Z movement at all using either Repetier-Host or the display on your control board will will engage the steppers.

I will give it a try. Thank you!!

Note ;that the g-code I provided can be automatically added to your g-code script. See Setup/CNC Programs/Texts/Program Start in EstlCAM.

There are other ways to solve this issue. It all depends on your process for setting up your job.

Well, the mpcnc is ohio state colors… :wink:

Your gocode is bad. You have no feedrates defined your Z axis is trying to move to fast so it just ignores the commands.



Edit… Regarding the idea of using blocks… if the steppers are powered down you have to assume you have lost position even if you did not see or hear it move. After setting up your zeros, the steppers must stay on until the job completes, otherwise there will be a loss of position.

1 Like