Can't get Ramps to connect to lcd or repetier-host

Hello. I live in Sweden and I am building an MPCNC as a School Project. I am having some issues with my machine. Everything until this point has been easy and fun to do, but I think I’ve messed something up at this point. I wanted to try my machine just to see if the motors spinned (had not placed the belts yet) so I install the software i needed and started trying to move it. Repetier-Host gave me “No start signal detected - forcing start” and all moves were put into the “1 command waiting”. I tried again and it still didn’t work. I unplugged the Power and started trying some stuff (note: I didn’t remove the usb Cable here as I didn’t understand that it supplied Power - this might have lead to more serious problems). I plugged in the Smart Controller and it was glowing but it was completely blank.

This is the point I notice the USB is supplying power. I try some things to make it work but to no avail. I go on and try and flash Marlin over again using the premade one, but I get this message every time. This is the Point where I find that Ryan tests all the sent away components so now that was to no avail as well. I have tried this with some different baudrates and on two different computers. Nothing is working. Another big problem is that I can only access the machine mondays and wednesdays, and next week is fall break so I can’t access it then. I cannot send it in or anything as I live in Sweden and there are horrible shipping costs and I’d love to not have to spend loads of Money to fix it. “Poor” student y’know. Anyway, I’d love to hear any tips on how I could be able to fix. Thank you all!

The LCD did this once:

Luckily you didn’t actually flash the board.

You bought it from me? What did you buy, Ramps, rambo, mini rambo? Is the LCD from me? how is it all plugged in, lets see a picture? Mac or PC?

I Did buy it from you, I bought the kit with no Changes (Ramps 1,4), The LCD is also from you and I’m using mac. This is the only pic of my wires when plugged into the Steppers (It’s messy, was planning on fixing that later)

Steppers don’t have anything to do with it though, as it still doesn’t work when plugged in without them at home.

Everything should work as is with the LCD, I’m guessing you just have the LCD wires swapped. Switch them on one end And I think you will be good to go.

Since it is a Mac some people have issues, see the first line of this page,

Firstly, not a mac, and secondly I still get the Repetier-Host “No start signal detected - forcing start”. There is something wrong but I cant find it.

Swapped the LCD Cables and the LCD didn’t start at all.

You said MAC?

Give me a few minutes to think about this, I have no idea what that error is.

Swap the cables back and try using just the USB or just the power to see if the LCD starts working.

Oops, sorry. I was thinking about other stuff and accidentaly typed Mac :stuck_out_tongue: I’m only using USB right now as It’s the easiest for me, but I can try using both and only Power.

Should also note - I’m not with the machine right now I only have the boards and the Power supply.

Any chance you can take an up close pic of the lcd adapter board as it’s connected to the ramps, then a good pic of the back of the lcd as it’s connected to the cables?

These the ones you need? Remember - the issue is not an LCD issue, its the board. Sorry for not replying for many hours, I was sleeping.

I only test 30% of the lcd’s but I test 100% of the ramps with an LCD so the problem is usually the LCD.

Was your LCD open or sealed in the anti static bag (tested or not)?

I think the best thing to do here is try to flash the board again, something might have happened on your last attempt.

Can you use my flashing instructions and let us know at what point you have an issue. Make sure that you have installed the drivers that come with the arduino IDE install.

I’ve used the flashing instructions and I’ve tried flashing more than once using your instructions and also testing the reset trick, nothing works. Why I know it probably isn’t the LCD is because the ramps wasn’t working to begin with, even Before plugging in the LCD. The LCD came in an open bag. The error comes while uploading and looks like this . I’m gonna try Another Cable if I have one and see if that does any change.

That error just says it never connected, and that is an arduino IDE error. What happens when you try and connect with repetier?

If your lcd was open that means your ramps and lcd were both tested, it is unlikely it is an lcd issue, it could be but I have only had a few problems out of more than a thousand sold.

At what step does my flashing instructions fail? Just the connection part? Do you see the right com port? Does it go away when you unplug the arduino?

Repetier-Host also says “No start signal detected - forcing start” and “Communication timeout - reset send buffer block” I am now trying with a new Cable, but it doesn’t seem to be helping. I am pretty sure that the issue is on my end, that I’ve handled it wrong or something, but the lights are shining and the lcd backlight is on so something must be working. The flashing instructions fail when uploading the firmware, and I do see the right port (It even says COM10: (Arduino/Genuino Mega or Mega 2560)) Probably doesn’t have anything to do with this but I noticed in the Ramps stack assembly part (Which I haven’t followed because it says I don’t have to, I just looked there) this Picture

There is no resistor or thermistor there. Thank you for still trying to help me.

We don’t use that resistor anymore, I thought I deleted that picture or clarified in the instructions about it.

What version of windows do you have? What else is using the other COM ports, maybe you can unplug some things, usually it is COM 3 or COM 4.

Have you changed the Buad rate settings in repetier, they should be on auto, or you can try 250000.

I’ve tried different Baudrates like 250000 and 152000. I use Windows 10 on all my computers. I tried changing COM ports, nothing changed. Changed computer too, didn’t work there either.

Extra info - I removed the Ramps and exposed the Mega 2560. When plugged into the computer one green light (ON) and one yellow (L) lights up and stays lit. When uploading RX blinks once but not more than that. Nothing happens when I press reset.