Connection trouble on new build

First off I want to thank everyone in advance for the help. I’m not a complete idiot but but definitely a halfwit…lol So I printed my own parts but got every thing else from here. I bought the

Mostly Printed CNC Parts Bundle × 1
6A / RAMBo Dual Firmware & Wire kit

I have the Machine put together and the wiring done and everything looks good. I connected the wiring to the Rambo and have the power light on the board. When i connected it via USB to my laptop it showed the port being found and the driver installed. It was a generic windows serial port. I installed ARDUINO 1.8.12 and Repetier-Host V2.1.6 following the instructions here “h.t.t.p.s://”. Once everything was installed I changed the settings in Repetier and tried to connect only to receive “No start signal detected - forcing start” followed a minute latter with Communication timeout - reset send buffer block" repeating.

So I google for a while and tried a few things to no avail, some of the things I tried where installing the driver from “h.t.t.p.s://” which did change the description in device manager. so i restarted my laptop and power cycled the Rambo and tried to connect again with the same result. I took a couple screen shots which are attached. Correction I attached one picture as I’m new so that is all I can, also not sure if the links will work for the same reason. Also if it matters I’m Running Windows 10 Home 64Bit.

any help would be awesome.

The drivers are only for windows 7. Arduino isn’t needed unless you are flashing the board (and you don’t need to, Ryan has already).

Two common problems:

  1. The rambo needs 12V power as well as usb. The USB powers the serial port, but it talks to nothing, so you get connection errors.
  2. If repetier server installs, it will run at startup and grab the port, start talking, and nothing else can see it. So if you jave RS, uninstall it.

Thanks for the response. I did have the server installed so I uninstalled it. I do have the AC adapter plugged in as well as the USB so I think it is getting the right power. I’ll add a picture of the RAMBo as well as some screen shots. But still can’t communicate. Should I also remove ARDUINO 1.8.12?

Arduino won’t hurt it. Are you sure you’re connecting to com4, and at 250k baud?

As far as i can tell in the settings. here is a screenshot is there anywhere else i should be checking?

Still can’t seem to get this to talk to a computer. I thought it might be a Windows 10 thing so I put Repetier Host on my Xubuntu laptop and tried it. No love, when I click the connect button after changing the appropriate settings, nothing happens, it doesn’t even log anything like in windows. I went in to terminal and ran the usb devises command and it does see it. this is what it shows if this helps.

T: Bus=08 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 2 Spd=12 MxCh= 0
D: Ver= 1.10 Cls=02(commc) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
P: Vendor=27b1 ProdID=0001 Rev=00.01
S: Manufacturer=UltiMachine (
S: Product=RAMBo
S: SerialNumber=75535313630351B09090
C: #Ifs= 2 Cfg#= 1 Atr=c0 MxPwr=100mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=02(commc) Sub=02 Prot=01 Driver=cdc_acm
I: If#= 1 Alt= 0 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=cdc_acm

Any Ideas or help would be greatly appreciated.

Looks like it sees it to me. Is there a new device like /dev/ttyACM0? I usually plug it in, wait 10 seconds and then do dmesg to see where it put the port.

You don’t need any drivers in Linux.

Do you have a blown fuse or something? If you unplug the USB, do you still have any LEDs lit up?

I’m back on the Windows Machine at the moment but if the 12v is plugged in and I unplug the USB the green power light does stay on but that is the only light that stays on most of the time. When RH sends a command I do see an amber light flicker in the middle of the board but that is about it.

Also just went into device manager and turned on show hidden devises and found this… should I remove the COM3 one?

I got excited when you started looking at linux, because I don’t know windows at all.

I can switch back if It will help, It’s just an old laptop. I removed both and restarted and it reinstalled on COM3 although it did dawn on me the other one was probably my Robo 3D R1+ 3d Printer

Don’t do it just for me. This should work in Windows. I am assuming someone else will pop in with the solution soon.

No problem just had to run in the house and grab it and get it fired up. This is the end of dmesg.

214.611631] usb 8-1: new full-speed USB device number 2 using uhci_hcd
[ 214.828511] usb 8-1: New USB device found, idVendor=27b1, idProduct=0001, bcdDevice= 0.01
[ 214.828518] usb 8-1: New USB device strings: Mfr=1, Product=2, SerialNumber=220
[ 214.828522] usb 8-1: Product: RAMBo
[ 214.828527] usb 8-1: Manufacturer: UltiMachine (
[ 214.828531] usb 8-1: SerialNumber: 75535313630351B09090
[ 215.026380] cdc_acm 8-1:1.0: ttyACM0: USB ACM device
[ 215.028819] usbcore: registered new interface driver cdc_acm
[ 215.028822] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters

I also tried the port of ttyACM0 and the USB port that show up and like I said before it doesn’t even try to connect. I hit the connect button and nothing changes… Suggestions?

It should be /dev/ttyACM0.

You may need to be in the dialout group. You can do ls - al /dev/ttyACM* to see the permissions.

owner@owner-pc:~$ ls - al /dev/ttyACM*
ls: cannot access ‘-’: No such file or directory
ls: cannot access ‘al’: No such file or directory

Oops, sorry, phone keyboard:

ls -al /dev/ttyACM*

LOL I should have caught that not your fault…

owner@owner-pc:~$ ls -al /dev/ttyACM*
crw-rw---- 1 root dialout 166, 0 May 23 19:29 /dev/ttyACM0

You can check if you’re in dialout with groups.

owner@owner-pc:~$ groups
owner adm cdrom sudo dip plugdev lpadmin sambashare

You can add yourself to dialout with:

sudo usermod -a -G dialout owner

(I think)