Crown Cut, Freezes close to beginning. -solved-

I can controll my LR2 by using the LCD or repetier-host in all directions: X, Y, and Z. But am having trouble with my first cut using gcode and repetier-host.

I am trying to do a dry run for the crown tutorial engraving. It freezes and makes a weird noise after the first couple of quick steps. I am confused what is happening. I’ve made a video that shows the gcode, the error log, and the movement then freezing of the router sled. Let me know if you need any more info.

the quality of that video was bad, I’ll upload an HD one so you can read the text if needed.

Edit the above video should be HD now.

Change your M3 to M03, or remove those lines, you’re probably not using them anyway.

What happens when you use the buttons to move it 50mm?

1 Like

Thanks for the idea. I tried your suggestions, and no change. It still raises then moves and gets stuck. It got me more confident in changing some of the G code though and look at wikipedia’s g-code page. I then tried to remove a few other commands.

I noticed after removing the F command (feedrate) the cut wouldn’t freeze. I removed all F commands, and I could run the entire file without problems. I am wondering if feedrate is for 3d printers, which this is not, and that is what is causing the problem. Are the F(eedrate) commands necessary for a CNC router?

Following the crown tutorial was a little difficult at times because the software seems updated since that tutorial was made. Some of the options have been moved or renamed. I may have missed a setting or messed another setting up. I’ll take screen shots of my estlcam settings soon.

I gave this a try for all directions and there seems to be no problem moving the sled around.

In the new version of estlcam there’s a line to start your spindle speed in the Start G-Code it needs to be removed. At least that’s what I had to do to make mine work.

 

In EstlCam go to: CNC PROGRAM SETTINGS/TEXTS tab. Then under Program Start remove the line referring to the spindle speed if it’s there.

Disclaimer… I’m SUPER new to this. It just sounds like the same issue I had.

 

Thierry

1 Like

I am happy to learn from new people as well. I tried what you suggested, and it essential resulted in what Barry was suggesting me to try and I got a similar result of the sled freezing up.

I did my best choosing the setting pages that may apply to my problem and taking screen shots of each. I did this for both estlcam and repetier-host. My initial guess was that estlcam was placing feedrate into my gcode because it thought I was printing, even though I told used the engraving method as described in the crown tutorial. But I have yet to find any settings inside of estlcam that would suggest it thought I was running a 3d printer instead of a cnc router.

Ah, sorry to hear that didn’t work. My program start looks like this:

G92 X0 Y0 Z0

G90

 

And that’s it. I’ll maybe try and load Estlcam on a different computer later and see what else I changed from Ryan’s tutorial. I was the same way, followed it exactly and got hung up on the software differences due to the new version. If I find some other deviation I’ll post it here. Good luck!

I’ve tried with and without the “M03 S24000” line. Here is the first several lines of unedited g-code that causes the sled to freeze after moving to the first cut:

G90 M03 S24000 G00 X0.0000 Y0.0000 Z0.0000 F2100 G00 Z2.0000 F400

;No. 1: Engraving 5
G00 X7.3454 Y35.4795 F2100
G00 Z0.5000 F400
G01 Z-0.5000 F3.000 S24000
G02 X14.2115 Y22.3227 I-85.3928 J-52.9336 F15.000
G02 X17.8652 Y11.0837 I-56.3770 J-24.5412 F15.000


When removing all the “F” codes it no longer seizes during the cut. Here is a sample that continues the movements, note the lack of “F” codes:
G90 M03 S24000 G00 X0.0000 Y0.0000 Z0.0000 G00 Z2.0000

;No. 1: Engraving 5
G00 X7.3454 Y35.4795
G00 Z0.5000
G01 Z-1.0000 S24000
G02 X14.2115 Y22.3227 I-85.3928 J-52.9336
G02 X17.8652 Y11.0837 I-56.3770 J-24.5412


Before I manually remove those “F” codes from every cut job, I wanted to make sure that removing them is not going to mess up my cuts or damage my machine somehow. If it is recommended to remove the “F” codes, is there a setting in either estlcam and/or repetier-host that would automatically remove those “F” codes? That would be ideal over doing a search and replace every time I use estlcam to make my g-code.

My Crown Gcode should work as is. What happens when you run that?

1 Like

I guess more detail would help. If manual controls work it is a gcode thing. My Gcode is verified to work on all machines. That should work if manual controls do.

You are right, your code does work without a hitch. That is promising. Though your gcode also has “F” codes and it work fine. So that has me scratching my head.

I tried making a square in Adobe Illustrator then exporting it as a dxf I opened it up with estlcam and created the gcode. I ran that code using repetier-host and the sled freezes shortly after the beginning.

I’ll do a bunch more tinkering to see if I can figure out exactly what it is that is causing the sled to freeze shortly after the cut begins. In the mean time, could you point me in the right direction of what additional detail that would help you diagnose the problem?

Thanks for your replies, I am inching my way forward with all your ideas.

 

Let me see the gcode you just made First 20 lines or so. Knowing mine works makes this easier for me.

Found it

feed unit esltcam (settings )

 

1 Like

4th picture down

https://www.v1engineering.com/estlcam-basics/

That was it! I can now start cutting!!! My fault for not following the directions exactly. Thanks for figuring it out Ryan! And thanks Barry and Thiery for your ideas to try too.

2 Likes

Hi there. I’m John. New to the forum. New to CNC stuff. Been 3d printing for a while mostly making models in Fusion360 and sending stuff to my Monoprice Maker Select V2 to make scale models for my woodworking and fabrication projects.

I’ve wanted to go CNC for a while, but the cost of the pre-fab systems was too much until I found the V1 Lowrider, which can do everything I want for a very affordable price. I ordered all the kits and stuff from V1 and put it together. The instructions and forums on here are fantastic.

I used estlcam to make gcode on a SD card and print a crown and the pen slammed into the table and it didn’t go well.

I tried the “if you have trouble use this code” and it worked great!

I tried my own SVG design. It still did not go well. It would start fine and move over to where it should start cutting, the just freeze and start buzzing. I figured something was wrong with Estlcam and my gcode. I searched these forums and this thread was helpful but did not solve my problem. I re-checked all the settings.

There was an issue with the changing from absolute to relative coordinates in the preamble code. I think I got that figured. Also, I did not have the F:-repeat checkmark clicked on the ‘CNC program settings’ and I hadn’t unchecked the G02 and G03 arcs on the ‘CNC program setup’. Tried that. I still had the machine move over and freeze. In comparing the g-code from mine to the working sample, the F- speeds were different.

I greatly appreciate the detailed instructions with screenshots. Many trips from the computer to the basement with a card. I think I should put a box down there and run repetier, but it’s just going to be loud and dusty.

I found another post in a different thread that said to set the
“Feed unit CNC Programs” to Millimeter per Minute instead of MM/S

My Gcode came out much closer to the sample gcode and I was able to cut out my first project!

I just wanted to post this here in case other people were having the same problem. I think it’s a newer version of Estlcam out there or I’m just not good and following directions.

Thank you to all the active posters and answerers of questions.

John

1 Like

There are quite a few settings in estlcam basics. Make sure you’ve followed them all and your gcode should come ouf very close to the test crown.