Different problems on the three axes (including the Z buzz / dive)

Hi, it’s me again. Using parts entirely bought from you.

X - my rollers move a little independently of each other. The one farthest from the middle assembly gets a little bit ahead of the other. This is especially evident if the machine is going back and forth rapidly - the X roller on one side moves a lot more while the one on the other side almost remains stationary.

Y - it still feels rough when I move it by hand, and while the machine is running, that seems to translate into kind of bumpy/jerky movement. I’m holding out hope it’ll smooth out with use. Due to other problems I haven’t been able to tell yet if it really affects results.

Z - I have that “diving” problem I’ve seen elsewhere in this forum. Seems that under certain circumstances, and I still can’t really tell which ones (except it only happens while running, not under manual control), my Z motor makes a loud buzz and doesn’t turn when it’s attempting to go up. It only happens a few times while running, too, not every time - but the result is that the tool just gradually goes lower and lower until it starts to get buried and I kill the process.

Any ideas? I’m hoping the X issue is just that I didn’t tighten something correctly, and the Y issue might work itself out. I was able to find the most mentions of the Z thing here in the forum, and I tried a couple of the solutions but nothing seems to solve the problem entirely.

Sounds like you are trying to move too fast, what speeds are you using? The diving problem (anti backlash being too tight, since has been removed) hasn’t really happened with the new parts. Same thing happened on here or by email yesterday and he was trying to move at speeds well above the firmware maximums of 197mm/s x and y, and 8.7mm/s Z.

Try 30mm/s for the x and y, and 5mm/s for the Z. Does that fix it? If it does make sure you stay below the maximums.

The X/Y speed for my tool in Estlcam is 15.0mm/s, and my F(z) is 3.0mm/s. Is there somewhere else that the speed might be set or affected?

I had problems with the Z stepper skipping steps (at least I assume that’s what the buzz is), so I increased my Z driver voltage to 1v, and reduced the z maximum acceleration to 40, and that appears to have fixed it.

The increase voltage does make the z stepper get rather warm, but I can hold onto it without much discomfort, so it seems fine.

I think reducing the acceleration helped the most. Estlcam appears to have a bad habit of not specifying speeds on Z axis moves, so it likes to inherit the last speed used for x/y, which is way too fast.

I saw the acceleration thing as a proposed solution elsewhere here, and I’d like to try it. But I got everything out-of-the-box from vicious1, so I didn’t set up the firmware myself. Is there a guide on how you might check / set the acceleration? I’ve searched but I can’t find one. Or could you point me in the right direction on how I’d do it?

Unfortunately you have to modify the firmware. In theory you can alter it via the marlin interface, but for me at least it only allowed you to alter it in increments of 100, which is useless.

This means you have to install arduino, download the firmware, alter the configuration.h, then upload it to your arduino/ramps board.

These pages will help:


The original acceleration was defined as:

#define DEFAULT_MAX_ACCELERATION {400,400,55,800} // X, Y, Z, E maximum start speed for accelerated moves. E default values are good for Skeinforge 40+, for older versions raise them a lot.

And mine is currently: (changed 55 to 45)

#define DEFAULT_MAX_ACCELERATION {400,400,45,800} // X, Y, Z, E maximum start speed for accelerated moves. E default values are good for Skeinforge 40+, for older versions raise them a lot.

But based on the marlin page above, it’s been changed to

#define DEFAULT_MAX_ACCELERATION {400,400,40,800}

Hope that helps

Ohhhhh, OK. I’ve worked with Arduinos before, so that theoretically should be no problem. Thanks!

On the firmware page I have the new/old marlin update it actually has the lower accel already done so Just flash that one if you are uncomfortable.

The new marlin has been released so I need to start again, but I need to finish these instruction updates first.

I flashed the firmware with the Z acceleration changed to 40, but I still have the occasional buzzing problem. My X rollers are still out of sync too. I made a video:

https://www.youtube.com/watch?v=pHfM3th7Py4 on most of it you can see the X roller on the right side is moving more freely than on the left, so the axis is just kind of swinging back and forth. Toward the end there are two instances of the Z control doing the buzz/grind thing.

I did notice that after I had connected and moved the rollers a bit using RepetierHost (so the motors are energized or whatever), I’m able to move the left-hand X roller pretty easily, while all others resist being moved. Does that shed any light on the problem?

hmm, okay seems like a stepper is not connected, or is wired wrong. Disconnected it and switch it with another stepper. When energized it should be locked.

Still seems like your z axis it trying to move way too fast. Lets see your gcode.

I will try to get another kind test code together (machine is apart to take pictures), I have three others up there somewhere. I am updating the instructions and looks like it would come in handy.

Keeping in mind I’m a newbie with MPCNC’s and don’t have much experience:

Wild guesses/things to check for the x-axis:

Are the pulley’s secured properly on the motors?
Belt tension on both sides roughly equal?
If the belts are removed, does the rail slide smoothly? If not, perhaps some bearings are too tight on one side?

For the z… Make sure the coupler is tight… Check the vref for the z driver? As I said, I increased mine to 1v. Mine sounded just like yours, I assume that’s “skipped steps”, but I don’t know for sure.

I don’t have a machine to try it on today but this should be good to go.

circle-test.zip (39.8 KB)

@vicious1 thanks, I’ll try that. Is it possible there’s a stepper problem when one motor works and the other doesn’t, and they’re both connected to the same stepper? I will try switching things up though, to see if I can get that loose motor to lock when connected to one of the other ones.

Looking at your gcode, it dawns on me that I may have used the wrong file, that I created before enabling the “add F to every instruction” thing in Estlcam. I’ll double check that.

@Scott I’m pretty sure everything you asked about is good, but I’ll double-check. I did verify the vref for the Z driver but I haven’t tried increasing it yet.

ARGH! I re-saved the gcode from Estlcam with “repeat F commands” enabled, and a few of the Z commands are set correctly to 180, but the rest are set to 900! Anyone know offhand where I can fix that in Estlcam?

I changed around my motors/steppers and it remains the same - one motor is locked and the other still has some play. I discovered that the same is true on the Y rollers but much less so. In both cases, it’s the one that’s more distant from the driver, if that makes any difference. I did check that the wire connection between the X motors is secure.

Slow down. You are changing too many things at once. I am lost.

You physically moved the stepper and that same roller is not moving? That would suggest your belt is too tight, your roller is too tight, or you have a bad wire.

Lets do this one issue at a time, because you are having so many issues I am guessing a build problem like bolts are too tight.

To do these tests stop using gcode, for now, one less issue to deal with. Use repetier through usb to your machine. Issue manual commands. Move the x and y axis back and forth 100mm a few times? Any issues?

Use these speeds in repetier.

OK - under manual control everything goes just fine. In general the machine is able to move around on X and Y very well.

What I meant in my previous post is that, when the motors are energized, I can wiggle one entire X roller assembly by hand (several mm in either direction) but I’m not able to move the other one at all by hand. For further testing, I unplugged the X and Y plugs from the RAMPS board and swapped them, so my X rollers were plugged into the Y driver and vice versa. After that I energized the motors again and I was still able to wiggle the same one. I don’t actually know if this indicates a problem or not. I put everything back the way I started though.

To sum it up, I have two main problems right now. One is that one of my X rollers gets a little ahead of the other one, as you can see in my video.

The other is the Z motor grind/buzz thing, but I’m pretty confident that’s a problem with my gcode generation because when I read the gcode, most of the Z axis commands have F900 with them (which is my X/Y speed) instead of F180 like they should. A few do have F180, but I think it’s just the first one in each cut.

Sticking with the x and y problem.

That does not make sense, manual control works fine? When do you get the wobbly axis then?

By you swapping the x and y at the board you have narrowed the problem down to either a bad stepper, wiring, belt, or hardware on the affected axis (basically you verified the arduino and drivers are good). Physically swap out the one affected stepper to find out if it is the stepper or the other issues. You could also take off the belts and check each stepper for motion/torque. Generally the stepper will either turn at full power (correct), make a bunch of noise (wires got swapped), or not move (no connection), or possibly one coil is disconnected and you are getting very little power.

A belt that is too tight will stall the stepper and it will lagg behind, bolts too tight will have too much drag and lagg behind, no power down the wires to that stepper will not energize the coils and it will just go along for the ride.

Just for giggles, unplug the X stepper that doesn’t wiggle, then try moving X with repetier. Sounds like you have either a bad wire to that stepper, or the stepper is bad.

Well, I disconnected the good X stepper and found the bad one didn’t move at all. I pulled the wires out again and disconnected/reconnected them again, and it started working. I did that once before, but apparently the connection came loose right away inside the conduit. I’ll definitely wrap that connection securely with tape now, and maybe do that loop trick with it too to make it more self-disconnection-resistant.

I’m so sorry, guys, I feel dumb for not figuring that out sooner. I guess I underestimated the extent to which just one working stepper can move the entire assembly. I wish they included LEDs or something to make them more idiot-proof for idiots like me. :slight_smile:

I did notice that once I reconnected the good X stepper, it didn’t work at all until I fully unplugged the RAMPS board then plugged it back in. Maybe that was part of my problem all along too.

In any case, it moves very solidly now, and I’m pretty sure the Z problem was because of F900 being generated by Estlcam. Hopefully I’ll have some nice things to show off in the “build” forum soon.