Estlcam under Linux?

I am a long time (mostly satisfied) Linux-only computer user … Any chance to get Estlcam to ran e.g. under wine, virtualbox, qemu? Any experiences available?

1 Like

I have ran it in a Windows guest VM using VmWare, so it should work as well inside VirtualBox.

It would be interesting to try it out using Wine, 2.0 was just released…

I have it working under wine (playonlinux, actually) and it works fine. The fonts don’t work right, and the file browser is a windows file browser, but other than that, I have no complaints. I also have it installed in a VM, in case I need to do fonts, but honestly, it’s easier to use inkscape to do writing anyway.

I roughly followed this, IIRC:

Specifically, there was a useful post with these instructions:

I got it running on my Laptop, seems to be running fine

Here are some hints for installing it under playonlinux

  • Select a 32bit windows (64 bit may or may not work)

  • Customize the components (winetricks for plain wine) and install the following:




My laptop also had “POL_Install_corefonts” installed, but when I attempted to verify the installation procedure here on my stationary pc it caused all text to look like it was written in Greek.
Seems to work just fine without the core fonts.

This was verified / attempted using an unregistered “Version 7.622 / 6th May 2015” release.

I’m 90% sure I just found packages that were similarly named to those above, but I can’t see how I can check how this one is specifically installed. There’s this “playonlinux vault” thing, but I’ve paid for my copy, so I don’t want to share that, in case it puts you on my license.

If you know more about playonlinux, tell me which file to post, and I’ll get it for you. My playonlinux is version 4.2.2, and I’m on ubuntu 14.04.something.


Update: 16.04 and EstlCAM 10 has been working fine too.

Update: 18.04 and EstlCAM 11 is running fine on my new computer.

1 Like

I’ll have to give it another try. I had seen that post on cnczone and that was what I followed as best I could…but I’m not very familiar with playonlinux and some of the packages didn’t seem to match up. Could also just be the old notebook I was working on the issue since it was an older 32bit system.

I’ll have to boot up linux on my shop computer this weekend and see if it does any better (it’s only 4 or 5 years old but sadly my newest computer…well…other than the macbook air I get to use from work which I do most of my onshape work from.)

Let me know if there’s a screenshot you need or something

I’m pretty sure those (or similar) are the instructions I last tried but that was the better part of a year or more ago. I’ve been using 4G/32G Chromebooks and Crouton/Ubuntu almost exclusively for nearly two years and couldn’t be happier… except for Estlcam. Sketchup runs beautifully under Wine on these machines… Inkscape, Onshape, Tinkercad, Slic3r, RepetierHost, Openscad, ArduinoIDE, most gcode senders, etc. all run fine on these modest machines. Estlcam, as good as it is and as much as I’d like to use it, just isn’t enough the attraction or necessity to me to warrant firing up the Windows7 box just for that… and so it sits for months on end. But that’s just me.

I’ll have to give Estlcam/Wine another try and see how far things have come. – David

SketchUp is one I’ve never got working in wine. I tried but the opengl was just black. I wouldn’t mind getting that fixed. I do like SketchUp for some CAD tasks.

The Opengl thing is a registry setting IIRC. I’ll try to look it up but you can google the opengl error message verbatim and it’ll put you on the right track I think. I have SketchUp 8 installed for compatibility reasons… buddy and I used to generate/trade designs and cutfiles and needed to stay on same version. But, honestly, I seldom use SU at all anymore… we aren’t building/flying too much anymore. It does, however, generate good, Marlin-compatible gcode for the needle cutter with the SketchUcam plugins.

Take a look at this for the opengl problem…

If anybody wants to try on Linux, I am experimenting with the following script.

Estlccam is working for me.
The script installs a downloaded 32-bit version of Estlcam.

cat ./

machine control with serial port doesn’t work for me.
You have to adjust the setup-name of the downloaded file in EC
and the installdir in WF

I hope it helps.


peter@ubuntu:~/cnc/3dSlicers/estlcam$ cat

From the command line install and setup wine and winetricks:

#sudo apt-get install -y wine winetricks

installs wine & winetricks on Ubuntu

Installname, for 32 Bit. 64 not working


New Install directory with own wine installation, just for Estlcam


#want a new install?

take care of the content of variable wf. you could ruin your full installation if it is not set.

rm -rf $wf


IGNORE Serial setup, is not working. Help needed

I am trying to get the Serialcomport working, which doesn’t work for me

#ln -s /dev/ttyUSB0 ~/.wine/dosdevices/com1
#ln -s /dev/ttyUSB0 $wf/dosdevices/com1
#ln -s /dev/ttyUSB0 $wf/dosdevices/COM1
#ln -s /dev/ttyUSB1 $wf/dosdevices/com2


WINEPREFIX=$wf wine regedit

WINEPREFIX=$wf wine regedit -E registryEst.reg

WINEPREFIX=$wf wine regedit registryEst.reg

WINEPREFIX=$wf wineserver -k


Follwing should be in regitry, doesn’t work for me

#[Hardware\Devicemap\Serialcomm] 1015709345


wenn das Programm im startverzeichnis von wine ist,

dann ist es schon installiert und kann gestartet werden

if program in directory just start it end exit when finished

if [ -e $wf/drive_c/Program\ Files/Estlcam10/Estlcam32.exe ]
# START in console
#WINEPREFIX=$wf wine $wf/drive_c/Program\ Files/Estlcam10/Estlcam32.exe

# Start in background
WINEPREFIX=$wf wine $wf/drive_c/Program\ Files/Estlcam10/Estlcam32.exe &



else install, run setup and start

WINEPREFIX=$wf WINEARCH=win32 wineboot

Creates 32 bit “wine” folders

WINEPREFIX=$wf WINEARCH=win32 winetricks dotnet40 gdiplus d3dx9_36

Installs 32 bit “windows” dependencies into the 32 bit “wine” folders

Download and install Estlcam:

Download program from

cp $EC $wf/drive_c/Program\ Files/

Put setup program into 32 bit windows directory

WINEPREFIX=$wf wine $wf/drive_c/Program\ Files/$EC

Installs Estlcam

Run the program from command line:

#WINEPREFIX=$wf wine $wf/drive_c/Program\ Files/Estlcam8/Estlcam.exe
WINEPREFIX=$wf wine $wf/drive_c/Program\ Files/Estlcam10/Estlcam32.exe




Thanks for the good information. I was able to setup Estlcam in Ubuntu 16.10 and register the software. I can create and export code. And I am thinking maybe this is how you use the software, actually printing/routing from some other software.

I would like to connect to /dev/ttyUSB# but cannot. I have tried adding the devices to the wine directory and modifying the wine registry, neither of which get the ports working/to program the Arduino. I use a different laptop for that.

So if you could confirm that your ports work then I will encouraged to continue my efforts to get my USB connection working.

Again, thanks for the info here. My Ubuntu/Unix prowess is minimal, but perseverance usually gets me over the line.

CNCing is split up a little differently than printing. There’s basically the CAD, then CAM, then running the gcode, which is usually done via SD card from the LCD, or via some gcode streaming software.

I don’t use the estlcam firmware. I just export the gcode. Once you have that, you can run it in pronterface or just copy it to the SD card. There is a pretty nice cli version included with pronterface if you like that sort of thing. Another popular choice is repetier host. Ryan’s guides follow RH’s setup. Once you have one of these working, you can move the machien around, and do the crown drawing to make sure your machine is set up, and then start cutting something forgiving like foam to get some experience with CAM.

If you’re just starting with CNC (coming from 3D printing), I would highly recommend staying with the Marlin firmware until you get a sense for the process, and what some of the settings will do.

I actually use grbl for my firmware, flashed onto a piCNC that’s attached to a raspberry pi, but if I have any trouble, there’s no one here that can help. When I was having trouble with Marlin, there were lots of posts here about it, and Ryan and others were happy to help me work out any new problems I found.

This post is about estlcam in Linux, so sorry to divert so much. I have no idea if any of the port stuff will work in Linux.

1 Like

I finally got Estlcam running with a fresh install of Mint 18.2 and PlayOnLinux. Purchased a new license key and applied it… went well. Now just need to get up to speed using it :wink:

Easiest way to find which port is being used… “dmesg” in terminal, check last messages displayed… plug/unplug and rerun a time or two… you’ll see it there somewhere, usually /dev/ACM0 or /dev/USB0 for me. Set that in Arduino IDE, Rep Host, etc. Works for me :slight_smile:


1 Like

Thank you for your input regarding getting “Extlcam running.”

I can do everything in Estlcam/wine setup except communicate via USB connected device.

I have no trouble finding the USB in UNIX/Linux and use it with Arduino and other tools. In Estlcam under Setup/CNC-Controller in the USB/COM port: box, nothing appears, and duplicating the “Arduino or dmesg connections” by typing it in does not result in device recognition.

Reloading operating systems and software, is a vortex one’s life disappears into. Fingers crossed, I entered this time sucking black hole but did not find nerdvana. Mint behaves identically to Ubuntu for me. Possibly my Linux PC.

Estlcam runs fine on my win10 PC, but I prefer not to drag that one into my 3D pit of doom. For now this is what Ive been doing, maybe later use Jeffeb3’s approach and print with some other software off my Linux PC.

Given you have ports running in Mint/Estlcam, (you have loaded firmware to your board and/or used the CNC-Controller interface to move your router?) I will pursue this a while longer, then probably go back to Ubuntu.

Thanks again

I’m sorry I misled you and prolonged your misery… I misunderstood what you are trying to do. You’re apparently trying to use Estlcam’s CNC Controller functionality… and since Estlcam is a actually a Windows program I’m not shocked that the CNC controller and port identification would not work under Linux. I don’t use it that way… I’ve only used it for CAM and generating gcode. I suspect Windows will be your only option for that functionality.

And, not a “vortex” for all of us… I made my OS choice a long time ago :wink:

– David

You could try windows in a VM. I did that for a while, but once I switched to OnShape, I stopped using that too.

The Marlin firmware is good though, I don’t think the EstlCAM firmware (or directly connecting from EstlCAM) will improve anything.

I learn from such dabbling, so no harm done. I have always had a dedicated windows box for my CAD but adopted Ubuntu for my makerbot thingomatic some time ago and now a dual extruding Ord. I mess with creating android apps, arduino code and so on, but I’m purely a hack and I’m scrambled making everything is a vortex to me. So pardon my odd jargon.

For this CNC router I first intended to run GRBL on a Mega but when I homed in on Estlcmam for CAM the options changed. For now an UNO with the Estlcam firmware to no doubt change my approach in time.

Oddly my laptop screen is happier with the Mint and as I see no essential difference I am not compelled to change back.

I see Onshape is a cloud (remote server) indulgence. All the rage having our data bits out and about, packeted through a myriad of processing nodes. Good to embrace and take advantage of techno variety. At $125/month though, it’s a little out of my price range. Besides, I have access to good CAD, but the CAM is mostly a hobby.

I just use it for free, everything I cad can be public. Doesn’t bother me.

We all learn from dabbling… that’s what we do. A 71 year-old, retired engineer, I’m a dinosaur among thoroughbreds… so all my jargon is odd… and my mind increasingly clouded and easily confused. It’s getting harder and harder to keep up but I’m having fun trying :wink:

Depending on how hardcore you are, Mint is Ubuntu… in its nicest, most-polished, dress IMHO. For years now, Mint has been the most “popular” and highest rated distro out on Give it a chance and I think you’ll like it. I installed Mint just because it’s been several years and I wanted to see where it is now… and to see if I could get Estlcam running on it. I “inherited” a terrible Toshiba Windows 8 laptop that was so slow as to be useless, and nobody wanted, and took great pleasure converting it over to a Linux/Mint box… it’s still crappy for CAD/CAM but, hey, you can now browse, interact with the forums, and watch Youtube videos with it :wink:

I’ve built numerous CNC machines of varying configuration – MPCNC, CoreXY, Phlatprinter-style – using the Marlin firmware and it works a treat and is easy to use and set up… I don’t need anything fancy. I’ve also built GRBL-based machines (Shapeoko2, Makeblock) and actually started with EMC2/LinuxCNC and a couple of BuildYourCNC machines. SketchUp/SketchUCAM, Estlcam, Inkscape/Gcodetools/JTechLaser, etc. can all generate Marlin-compatible gcode now and, with a gcode file in hand, any number of sender/controller programs run in Linux. I almost exclusively use very modest Chromebooks with Crouton/Ubuntu to run all my CNC machines now. That is, unless I set them up “headless” with an LCD screen and SD card. Estlcam, popular here and elsewhere, was the only program of interest I hadn’t gotten to run on Linux… but I had enough Linux-friendly alternatives so that the one Windows7 laptop that I had Estlcam8 installed on wasn’t fired up more than once or so a year, if that :wink:

I’ve recently built a Openbuilds C-Beam machine primarily just for something different. I set it up with GRBL/Uno, which seems the way most folks set it up… but to be honest, I’m seriously considering switching it over to Marlin and setting it up to run from LCD/SD, just to be different and because I can. I’m familiar with that workflow(s) and it all just seems more intuitive to me now.

Onshape is free and fully-functional… if you don’t mind all your work being public. For me, that’s fine. I can’t begin to tell you how much I have benefited from all the generous, helpful, and talented folks that inhabit this, and other forums, I frequent… and if I have an idea or some tidbit of knowledge that would be helpful to someone else, they are welcome to it. I love interacting with folks who have something to share… and, to be honest, I have absolutely no desire to take any personal “trade secrets” with me to my grave. :wink:

YMMV. – David









1 Like

I think of myself as semi-retired. That is I still contract out for a fun project, though I spend little time beating the pavement. I worked in an engineering capacity for a fallen high tech giant most of my career, though I’m of the mechanical and industrial design ilk. I have always excelled at CAD and as such invested in Alibre/Geomagic. With patents under my belt I’m reticent to put my more creative stuff out there. But I do intend to share some stuff on my web site currently awaiting my attention. (so much to do)

In the working world you can be part of a team and things can happen quickly. On my own, I am the team, the world is a toy store for those of us with a propensity to create and techno-lust running through our veins. With the plethora of things I want to do, and the seasonal influence on what to do when, the concept of retirement takes on new meaning. We need another word like self-deployed or a different emphasis like re-tired.

Anyway, good to know Onshape is free, I had just perused the site and thought that applied to teachers and students but clearly that is not the case.

With both of you expressing good things about marlin, I will have to have a closer look.

On the estlcam front, I dug up an old XP laptop which is able to run it. XP is slow to boot, no longer supported and that machine is IDE, but it keeps my primary PC out of the dust.

My CNC is home built, has 21X35 inch travel on supported rails, runs on NEMA 23s with ball-screws, and is made from plywood and printed parts. So fairly traditional construction. It appears to work fine though I still need to tweak things and as the cold weather will settle in soon, it may not get a lot of use out in the uninsulated garage until spring.

1 Like