pre owned mpcnc help

I recently purchased a completed but used mpcnc with the impression that all I would need to do is install the software to make it work and tadaa it would. After you stop laughing, maybe you could help me get it going. I have installed (to the best of my ability) the programs recommended : ARDUINO, REPETIER HOST, ESL CAM. Yet I am unable to get the board to communicate with my pc. I have also tried to follow the V1 instructions, but they are not completely clear to me. I am using it as a router, not a 3D printer. I can control the steppers manually with the LCD screen, and it shows that an SD card is inserted, but will not show its contents. also this may be a long shot but if someone wanted to walk and talk me thru it on the phone I would be willing to pay some money for that time/effort

Start on this page let us know if you have an issue, or show us the crown if you get that far.

 

https://www.v1engineering.com/assembly/software/

1 Like

that was the first place i went. I cannot get the repetier host program to talk/connect to my cnc. My board has a usb to “printer style” cable that is connected. otherwise i do not know how else to get them to communicate

Do you have a USB-B cable, instead?

something like this:

Make sure you have one or more files with the .gcode extension on the SD card.

for example, this one:

https://www.v1engineering.com/wp-content/uploads/2015/09/Test-Crown-12mms.gcode

yes it is a USB type B cable. How do I get the Gcode onto the sd card, it wont let me copy and paste it.

Do you have an SD Card slot on your laptop? or a SD Card Reader connected to your pc via a USB cable? If so, go to “Computer” and view the driver letter that is used for the SD Card. Then find the .gcode file on your laptop and right click it. Then select “Send to” and select the drive letter of the SD Card. Now you have the .gcode on the SD Card. Next, go to computer, right click the SD Card letter and select “Eject”. Remove the SD Card from you computer and plug it into the Rambo card (unless you have a different card).

P.S. I’m only a half step ahead of you. /Tim

1 Like

In regards to sd card use I was having the same issues with mine. Here is what solved my problems

  1. SD card must be 8gb or smaller (bigger is not better in this case. I stocked up on them because it seems like the smaller capacity cards are being dropped by the manufacturers)
  2. G-code files must be in a sub folder of the SD card (I just have sub folders called A and OLD
  3. Make sure the files are being saved as .gcode
  4. Make sure write protect tab is in correct position on the sd card
I just drag and drop the gcode files into my sub folder A on my SD card on my computer. I also purchased a separate sd card reader for my computer (usb cord style) because the sd card slot on my computer is a PITA to deal with.

Hope this helps

In regards to the SD card and the LCD screen. This is what it is saying. I would still much rather prefer to have a direct connection.

I have installed the arduino, so should I flash the board as the next step even though it has marlin on it?

Duff - email me with your phone # and I will call you and try to help

dakotajim@midco.net

Is that the right firmware? I thought Ryan’s firmware had the V1 logo on the boot screen?

My Minirambo boots with the v1 logo and then the very first home screen says v1 on the bottom line.

 

Wow I did not even catch that, that is Marlin 1.1.5. I am not sure we ever had a version that old, if we did it was not for long. You need updated firmware for sure.

Ok thats good ish-news. I have an 8gig sd card waiting on me at home and will flash the board when i get off tonight and update afterwards…Is this the version I need?? ** MPCNC_MRambo_T8_16T_LCD **

no, you want the MPCNC_Rambo_T8_16T_LCD

the one you have listed is for the mini rambo

OK guys, sorry for the late reply I just now had time to work on it.

I swear I had the Arduino already installed but couldn’t find the program, so I did it again and that went smoothly.

I followed the board flashing instructions and it all went well until the end steps.

#1 I had more than one option of communication ports available so I just chose the top one (3)

#2 I didn’t have the firmware “marlin.ino” file, mine was a marlin/arduino file (see pics)

#3 the instructions said not to worry about an error after finishing the upload, but I can’t help but think my error is different. (see pics)

Needless to say it still won’t communicate with the repetier and the LCD boot screen still shows 1.1.5

It should not be COM 1, at least I have never seen it be anything less than 3. Your screenshot do not show the one thing that is usually the issue, What version or arduino. Your screenshot also shows you are trying to upload a blank sketch not Marlin.

The arduino is 1.8.9-windows… also I just realized that I needed to open the file INSIDE the arduino, not just on the computer. Duh that’s probably why it was blank

 

Just tried to correct it and this is what it looks like. Also another error

Is there more to that error?

Click on the configuration.h tab, scroll down to where is says board type. Or maybe show your control board and the file you are using you cut that off of your previous screenshot.

Also close the other arduino instance. One open at a time just in case.

This is what I could come up with.