SKR Pro, TMC2209, TFT V3 E3 -help wanted-

I’m in the same boat as Ron. Have the SKR v1.3, TFT35, but with 2208 drivers running dual endstops. I just added support for the V1 touchplate to the TFT config using the Home Z button. Really excited to see where this can go from here.

I also have the 1.3 , tft3t5 v2.0 with the 2209s. It’w working as is, but I’m willing to test as well.

I’m rocking the skr 1.4 turbo and 2209s and tft35 e3 v3.0 different main board but I am willing to help


I’m about to start assembly and I’m bought a BTT skr 1.4 turbo with 2209’s along with the 3.5" TFT.

What did you need to do to get it working?

I’m running skr pro v1.1 with TFT3.5 and a mixture of TMC2130 and 5160. Maybe worth noting that I’m on my second board, the first one popped. it was either ESD or the processor got too hot (was 30C ambient). Biqu has a new V1.2 board out that adds a transient voltage suppressor on the 3.3V line. So I soldered one in. Also glued a heatsink onto the processor with thermal epoxy. So far it’s working. I have the old board and bought a replacement processor ($12) so will try and swap it out to have a spare. If it works, then I’ll test your code on my MPCNC with a set of TMC2209s here.

1 Like

I used spinne-rw’s board firmware and don’t remember exactly what changes I made. Very few though.

I’m running a Lowrider 2 with a BTT SKR v1.3 with dual endstops, TFT 35 V2.0 with custom firmware, and TMC5160s. Have also used TMC2209s- these work very well, so I suspect the 5160s are overkill. I put a 12v relay on the fan output to switch the router on and off (M106/M107). That adds a nice level of security. It’s really nice to be able to play around with these configurations.

Moving my burly from Rambo dual to SKR Pro dual (with 5160’s and TFT35 v2.0), got basic motor movement working via the TFT. It uses E1 and E2 for the slave X and Y instead of the E0/E1 for Rambo.

Next is to get repetier working and home it with the dual endstops. I monkey’d with the serial settings in attempting to get the TFT to work (and it does work OK), so I may have broken the USB serial:

-#define SERIAL_PORT 1
+#define SERIAL_PORT -1

  * Select a secondary serial port on the board to use for communication with the host.
  * :[-1, 0, 1, 2, 3, 4, 5, 6, 7]
-#define SERIAL_PORT_2 -1
+#define SERIAL_PORT_2 1

Is reverting those likely to get both the TFT and USB serial (with repetier) working? I’ll experiment, but if anybody knows…

My firmware works as is with dual, tft, and USB as far as I can tell.

If it is of any help a SKR v1.3 has

#define SERIAL_PORT 0
#define SERIAL_PORT_2 -1

The pro uses a different chip and doesn’t have a zero. The tft is on 1 and the usb is on - 1. I have no idea what the consequences of using one or the other for SERIAL_PORT_1 or SERIAL_PORT_2. I would guess nothing is really changing though.

I reverted to Ryan’s serial settings, and it’s working, just not with my Mac (though a serial device appears in /dev when I plug it in). Windows (after installing drivers) was OK.

Endstops. I plugged in the endstops to match the motors (X, Y, E1, E2) and the endstop LEDs do the right thing (the E1 endstop blinks the E1 LED (nice feature)), but M119 shows something else, seems E1 (X2) shouldn’t go to E1 for example. I presume I need M119 to show the proper state before I let autohoming loose.

OK, trial and error on the endstop connections, X to X, Y to Y, Z to Z, X2 to E0, Y2 to E1. Homing worked.


I got wifely approval to build a CNC router table the other day, so I pulled the trigger on the hardware kit and the flats for the lowrider as I have some cabinets that I need to make. You probably packaged and shipped my box to Minnesota already Ryan. This is my first post here.

Anyway, I also ordered the SKR Pro, TMC2209 and the TFT35 based on the fact that it supports 6 stepper, and I plan to also do some large panel prints for some car parts. I need the surface area to run some ASA prints. I’ll be testing this firmware out as the first flash on my board. What I was wondering was if you had the connectivity diagrams and any jumper settings for how this particular board would connect up for the MPCNC with the dual end stops.

1 Like

Yes, I do. I will try to get some up soon.

I flashed your board and screen so once you install the drivers you should be ready.

I am not sure what I can get down tonight or tomorrow but I am assuming your box has a few days past that, so I will see what I can do. It is all available on biqu’s github but I can do a simple walk through as well.

1 Like

I didn’t get a board and screen from you, as I had already ordered them from Amazon, (Mine is order 12753), but I’m super pumped to get the Lowriderv2 built. Cabinets and then some wall-hung cat purrniture that has been in high demand ever since I built the first couple sets by hand and sent them out for testing. My next project will be the MPCNC itself, as soon as this one pays for itself.

I’m no stranger to electronics/wiring, I just have not worked on a multi-axis motor controller before, so my confidence level is a bit low. Either way, I am super pumped about this. I’ve had ideas stuck in my head for many years, but was never in a financial position to get a 3D printer until I hit the “ask forgiveness, not permission” phase. And once I started printing things that made my wife’s life easier, she said yes to the CNC. :smiley:

1 Like

@vicious1, it looks like my Lowrider kit should be here tomorrow, so I can get the steppers hooked into the SKR 1.2 they sent me.

Anyway, I got your dual endstop firmware compiled and flashed to the board, at least as far as I can tell. The board booted after dropping firmware.bin onto it, and then when I checked it later, the bin had been renamed to firmware.cur (which I take to mean it was flashed and is current).

I also flashed @jeffeb3’s TFT35 3.0 E3 firmware that he has been working on, and have the CNC icons/firmware set up.

Question, are you running in UART mode for your TMC2209s? What about stallguard? I don’t want to clip the pin if not necessary as I’m out of pin header components to resolder at the moment.

I’m reading up on Marlin 2.0, and it looks like you can now set it to Extruder=0 so pin remapping should not be necessary, so if that is the case, it should just be a matter of connecting the steppers to each of their normally assigned outputs and then creating and crimping all of the wiring and connectors so I don’t have any splices anywhere.

No stallguard, You can just bend the pin…in case that ever changes.

1 Like

Thank you. One additional question: Have you been able to get both the TFT in Touch Mode and something like Pronterface, Octoprint, etc working simultaneously?

I’m looking in the #define SERIAL_PORT section of Marlin. I have to tell the touch interface to disconnect from the SKR Pro before I can run Octoprint against the board via USB port. My understanding is that -1 should work for the primary serial port connection as this is a virtual port in use by the USB, so I configure that, and then I set 1 for SERIAL_PORT_2. This is the only functional configuration I have been able to get the TFT working on. Any guidance you can provide would be great as I’d like both the screen and a computer connection to work simultaneously.

I believe in that case you would have Octoprint hooked up through the TFT. You would use TX and RX pins on the Raspberry Pi and connect them to a UART on the TFT screen. There is a config.ini setting on the TFT to keep the connection even if in “Marlin Mode”.