SKR PRO V. 1.2 / TFT 35-E3 V3.0 Screen Black after Flash

Hey there… Not an expert and a bit out of my ballpark. So feel free to explain in detail.

What I have: SKR PRO V. 1.2 / TFT 35-E3 V3.0

Here’s what’s happened.

1: Bought controller and screen from V1
2: Ryan was awesome and helped me with a broken ribbon on the touch screen
3: New non-V1 screen arrived.
4: Followed steps and flashed the new component (TFT) It worked and everything was peachy. Then noticed it showed “No printer connected”. Tried to move the axis and nothing.
5: Suggested on FB that the baud rate needed to be adjusted to 250 000 and board reflashed.
6: Took the large SD and put reset.txt on it and put back in TFT.
7: Didn’t work that I noticed.
8: Put new firmware on. Screen then black and looked like it was not getting any signal.
9: Board warm around reset button.
10: Reset button now does not work on either the SKR or TFT.
11: FB help said to try reflashing the micro sd as that had issues. Did so. No green lights flashing.
12: Super down today. Waited a week for new TFT and hope I didn’t brick it somehow. Any help would be greatly appreciated. Fully aware ribbon cables need to be disconnected and followed steps from Ryan.!
13. Reset buttons are no longer working.
PXL_20210527_155728620|666x500

Are you able to reflash the board without the screen attached?

Nope. No flashing green lights.

Okay, this is an odd one.

First. Unplug all three lcd cables, take out all the drivers and unplug the steppers. You just want the SKR pro to have power only. Check to make sure all three fuses are still good. From there take out the micro SD and load it with the bin file from the instructions, instructions, file.

The skr pro and the screen have separate firmware. You do not need to edit anything, we have done all the work for you. Flash the board, and flash the screen and try again.

Tried last night until morning. Called it a night. Man cried into my Cheerios. No luck again now after starting again fresh. @vicious1

What happened, what did you try?

  1. Removed all drivers
  2. Removed all cables to TFT
  3. Checked SKR Fuses
  4. Deleted Firmware from Micro and SD Cards. Put fresh firmware on.
  5. Powered up SKR. No green flashing lights. Reset button dead.
  6. Put ribbons and rewired TFT. Nothing happend. Reset button dead.

Without the screen connected change the small single jumper to the usb side and try powering it only from the USB port.

Searched everywhere for a standard USB. Don’t have. Is this okay? If so, no green lights.

What green light are you looking for? The one for flashing, if so it only last a split second. If you put the bin file on there and it gets renamed to Cur than it worked. What does it say is on there on the computer you are plugged into?

This tells us there is either a fuse or power supply problem, your board looks fine with USB power.

Remains as .bin - Just removed and placed into the computer to confirm. All fuses checked.

Just to be thorough you unziped the file I previously link and only put the bin file on the card. Then rebooted the board?

Your normal operating lights are on, repetier host is not connecting?

Unplug the power wires as well just in case.

  1. Correct, Unziped the file you sent and rebooted.
  2. Removed Power
  3. Had no idea what repetier host is. Just downloaded.
  4. Not showing connection. Tried Com 3 and 4. See images.


Do you have another microSD you can try?

I just can’t think of any reason the USB power would work but not actual power. On top of that the flash/reflash should work if there is power. Does windows show a com port in use at all?

With just usb power and the black TFT cable does the screen turn on for you?

Ryan!!!

It just started working and reset back and TFT updated and logos proper! Then when I moved my hand it went black. I figured out it’s this guy! I unplugged it and it went back to working!!!

However when I plug the ribbon in. I get this screen and can’t select modes. Tried a reset.

Odd. That is the reset button from the screen.

The reset file is just a touch reset. Best to do a full set of new files while including that reset touch file just in case

For the marlin side you need both grey cables to read the SD.

Maybe try the other black ribbon you have

You’re missing a ribbon cable. Mine did that when I had the ribbon cables reversed. Make sure exp1 on the screen goes to exp1 on the board and exp2 to exp2

Thanks RobP. :slightly_smiling_face: I have two. They do. An FB user suggested one ribbon only would work. That was a shot of that test.