SKR v1.3 using skr13 marlin20bugfix_2208 changes

I could not get TT download to work so I found this file, skr13 marlin20bugfix_2208 changes. I had the connections on the board like TT, X moved ok but Y2 moved with it and Y moved ok but Z2 moved with it. I switched Y2 and Z2 around and Y and Y2 now move ok but X and Z2 now move together. Any ideas? I have been going crazy trying to figure this out.

Thanks

Sounds like you have a two axis duel stepper firmware setup for Lowrider but trying to use that on an MPCNC. What configuration are you hoping to achieve?

Lowrider = dual Y dual Z single X
MPCNC = dual X dual Y single Z

Perhaps you might be better served by starting simple and only using 3 drivers and wiring any dual motor axis’ you have in series…once you have that under your belt you can experiment with dual drivers.

lowrider. I wanted to use Teaching Tech setup but having trouble compiling using TMC2208 uart steppers.

The teachingtech firmware quickly got out of date. I don’t think it compiles with the latest versions of the tmc library.

You can try mine. I used it for 2209s. I didn’t attach endstops, but I did run 5 drivers on my lowrider. I also think I got the tmc settings right for cnc:

2 Likes

…or you could fix the issue with the TMC library…

Jeff is right, the later library versions do not work with TT’s firmware, you need TMCStepper-0.5.2

Are you using Visual Studio to compile? In the platformio.ini file, in the [common] section you will find TMCStepper@>=0.5.0,<1.0.0 you need to change that to TMCStepper@=0.5.2

You will also find the same line further down in the [env:LPC1768] or [env:LPC1769] section (depending on your SKR board version)…change that too.

Then go to the Platformio tab on the side of the screen (alien head) and find ‘clean’ and click on that - that will remove the existing TMCStepper lib from your build directories, then click on ‘Build’ and it should download the 0.5.2 library, you can follow what it is doing in the terminal window…make sure it uses the earlier version of the library and it should compile ok.

1 Like

That’s a good tip. Either way, you’ll have to adjust the drivers to 2208.

Thank you both for the info. I did install jeffeb3 files and they do work fine. I tried to fix my other file but I still get errors. the main one which I have been fighting is delete temp files and I can’t find how to do it. I will keep trying because I want to use the end stops. In the meantime I will continue learning with your working file.

Glad you got it working with Jeffs files. FYI if you get a message about the software being unable to delete stuff you should manually delete everything in the .pio directory and re-compile, it should then re-download the older libraries as specified in the changed platformio.ini file