Spindle on off in menu

I don’t really know if this is troubleshooting or not but seemed like the best place for it. I just finished up my Primo and was testing all the functions and going through the setup. Everything works great. I am using an SKR Pro 1.2 and a TFT35 and I have loaded the V1 firmware from the site. I noticed the menu had a Spindle On/Off screen and when On is pressed it turns on the HEAT2 output and applies 12VDC, I wired a relay to that output and that controls the socket for my router so I am able to turn on and off the router via the menu. My problem is, when I go to the Move screen and move the axis, the HEAT2 output turns on, which turns on my router. I don’t think I would want the router running while I am moving the axis in the menu.

Is that by design?
Am I not using the functions correctly?
Should I be connecting the relay to something different?

I am a newbie to cnc and this setup so if I am doing something incorrect please let me know.

Huh. That’s news to me. Does it happen if you don’t ever turn on the spindle? It might be set up for laser, and if so, it might be only turning on when moving.

What happens if you run the test crown? Does the HEAT2 turn on while running that gcode?

Yes, I turned off the power switch on the router and I noticed the green LED lights up when I move any of the axis and I see 12VDC on the output. I have not run the crown test yet, it was late when I finished so planning on doing that tonight.

How do I know if it is setup for laser? Is that an option?

@vicious1 enabled some laser features in v510. I haven’t tried them, but this seems like an odd side effect that could be because of the laser features that were enabled.

So, my question is, if you reset the skr, and don’t do anything to enable the spindle, and then run the test crown (just in the air is fine), does it turn on HEAT2?

OK, I will try the test crown tonight when I get home and see what happens and report back.

I can tell you that I reset the board, went directly to move and the spindle turned on as soon as I moved an axis. While the spindle was on, I went to the Spindle menu and pressed off, nothing happened. I then pressed on, then off and it turned off.

OK. That is news to me. I was really hoping we just needed to change an M3 S0 to an M5 or something.

Ran the test crown, HEAT2 turns on when I start the process.

1 Like

So do we think this is a bug in the firmware? Should the spindle start when using the move function?

I think it is a bug. But let’s see if @vicious1 has anything to point out.

I am pretty sure we can fix it by changing a setting and recompiling. But I’m not sure which one to change, or if you are willing to do that.

Sounds good, just let me know what to do and I will give it a go.

You can start by compiling the code as is by following the instructions for platformio.

I am pretty sure we can fix this by disabling the laser mode and enabling the spindle mode. But I haven’t looked closely at those in a long time. As a longer term solution (to try to work for everyone) we may need to look more closely at trying to set the spindle up on another pin, or something, while leaving the laser stuff alone. Ideally it would work for either, but the on/off patterns aren’t the same between them.

I have been following along. I need to test this myself. I am wondering if this is a TFT issue or Marlin issue.

Does the test crown still trigger the port if ran from the Marlin side of the TFT?

I JUST unplugged the skr off my MPCNC to test some returned boards, so I will try it out ASAP. No one else has mentioned this though.

I have not tried from the Marlin side, I can try that and see what happens tonight.

To cover my bases and make sure this isn’t a me problem and I did not screw something up… Since you were out of stock on the skrpro I ordered both from Amazon and the TFT I received was not the E3, it was the TFT35 v3.0 (accidentally clicked the wrong one when ordering). I was going to return it, but from what I can gather they were basically the same so I just rolled with it. I spent quite a while going through firmware to make sure I downloaded the correct ones but maybe its possible I used an incorrect version?

I had this exact issue! I am trying to find the line in the config that i changed to fix it. IIRC its a setting for the laser that’s doing it, and I think its also a setting that’s supposed to change the power based on movement speed, if that helps. Sorry was a while ago that I changed it. If I can find the setting I’ll post here.

That would be great. Thanks

Comparing my current, i believe its these 3 lines I commented out :-1:

//#define LASER_MOVE_G0_OFF

these are in the Configuration_adv.h

Let me know if this works for you. I have a lowrider and for me, the spindle on / off was working great. But every time i jogged it the spindle would turn on on its own. And it was a pain to turn it off again. Sounds exactly what you’re experiencing as well.


OK, I will take a look at it later. Thanks for the info

Some updates:

Double checked firmware I loaded and should all be correct.

Marlin mode will trigger HEAT2 when starting test crown after a boot/reset. When canceling or stopping, it will turn it off.

Touch screen mode will trigger HEAT2 starting test crown after boot/reset but will NOT turn off HEAT2 when canceling or stopping.

Both modes work same when just moving any axis, as soon as you move one it will trigger HEAT2 on and you have to go to the other screen and turn it on (even though its already on) then turn off to actually turn it off. Jus pressing off does nothing. Marlin mode calls it LASER, but touch screen calls it SPINDLE.

FYI - updated the firmware with those lines commented out and it seems to have solved the problem with the spindle turning on when moving axis. Thanks for the tip