Steppers moving at different rates

FW: v506 2.0.7

The steppers on x and y move at different rates. It seemed like one stepper on x and y were not working. Then I took off the belt and felt the difference in speed. One of the steppers spins fast enough to miss steps.

I’m at a bit of a loss for how to remedy this issue.

edit: I connected the endstops to the wrong pins on one side. I forgot the pins are flipped on the other column. I went looking for the labeled picture, but never found it. dang.

It is unclear here whether you have your problem fixed or not. It sounds like you only had this problem when trying to home and it was an end stop connection issue. You will find the labeled pins for various boards for dual end stops on this page.

1 Like

You should be able to do all the motions without the endstops connected.

Be sure to check that the pulleys are the same size. Be sure that both motors are actually driving. An intermittent wiring issue would slow down one motor. So would a loose gear/pulley on a motor shaft. But it would be strange that it would be both second motors.

One stepper turns a full turn and the other turns 1/8 of a turn. It was working before I loaded the new firmware and plugged the endstops in wrong. The endstops have been plugged into the correct location.

Plugging the end stops into the wrong location and powering up the board can damage your board. You are shorting positive and negative for those pins. I would expect that you would either burn out those pin, burn out a fuse, or perhaps damage a voltage regulator. Not sure if this is the root of your problems or not. Some things to try:

  • Remove end stop wires and test
  • Test the fuses
  • Regress to the old version of the firmware and test

Sounds like a good plan of attack. I did the endstop wire removal. I’ll test the fuses and try older firmware.

The fuses on the board are proving tough to test. The blade fuses all seem ok. I installed a older version of marlin with worse results. I wasn’t able to find a older version (pre 2.0) of marlin preconfigured.

Whoa. It sounds like the steppers are configured for different microstepping. This is an archim board? Did we miss a setting for confusing micro stepping?

It’s the Archim 1.0a board. I tried to find a setting that might have been configured improperly. I’m no expert on Marlin though.

I guess I’m getting an Archim 2 and turning this board into a single stepper per a axis controller.

The archim 2 won’t help. Can you share some pictures of how you have it wired? Maybe a video too showing how it is moving? It’s very odd.

We just worked this out about 2 weeks ago and Ryan was testing firmwares with an archim, and they aren’t magic, so I don’t know how it would fail in this way. Maybe some photos and a video will show me something I wasn’t expecting (or one of the other smart people here).

Yeah, I’ve never seen a failure of electronics in this manner. It seems to be something else. I’m not sure where to look. I appreciate you taking the time. I’ll get some video and pictures uploaded later tonight.

update: had a few things come up. I’ll try to get the pics and video later today.

1 Like

I loaded on a slightly older version and got a lot more noise and a lot less movement. I switched back to the newest version and took the video and images.

How weird.

@mattinglot and Ryan and I were working on this a little while ago, and I thought we had all the fixes into v506:

I just started a build on v507. That should be up soon. It shouldn’t be more than a day’s difference, but it would be great to know if this version is still doing it.

There is another archim user (@mperino) with suspiciously similar issues: Tuning Drive Strength and Steps per MM on Archim 1 for V506

And I know @vicious1 has one. We worked pretty hard to get the last one up and running. It is disappointing this one isn’t just working.

It’s also very clear from the video that the fast motors are wrong. Are those plugged into X and Y or E0 and E1? I wonder if we are missing a microstep setting on the extra motors.

It looks like we are setting “MICROSTEP_MODES” to 32,32,32,32,32,32. That might be looking at a bit closer (should it be 6? Is 6 enough? Does the X2, Y2 get set with those?).

Oh, This is set in the EEPROM…

Can you send M350 and see what that prints?

let me see if any changes were made to marlin after the fix.

Shoot there have been a few digipot changes. Probably need to test this on tomorrows build and release 208…

X and E1 are the ones moving more than they should.

Those don’t seem important to me.

Here is my theory. That microstepping setting might be saved to eeprom. For some reason, it has junk in Dave’s eeprom. I’d like to confirm that with an M350. But an M502 should fix it.

Dave, do you have a computer you can connect with repetier host or cncjs or something?

It’s still doing the same thing after the command.

Send: M350
Recv: MS1|2|3 Pins X:000 Y:001 Z:000 E0:111 E1:000

Send: M502
Recv: echo:Hardcoded Default Settings Loaded