Trouble with Z axis raising above material plane between cuts

Hello All,

Love the machine, loved building it.

I build a full complete kit from MPCNC.

It went together nice, following the directions.

I am running Widows7, Estlcam 10.
The control panel in Estlcam moves the Gantry in all the correct directions.
I built it 40"X40", which gives me about 29.5" square cutting area. 5" legs, and a 12"Z Axis.

When I practiced with the pen attachment, Z did not raise off paper between line sections.
Then I tried to put my dremel on the Gantry, all snugged up.
I am saving for the Dewalt router.

Tried practicing on a piece of foam board. Still Z is not raising above the plane of the material.
I set the Z axis to zero with the tip of the bit touching the top of the foam.
It goes down a little and begins the design.
never lifts above the top of material.

I saw in the Estlcam instructions to reverse the Z direction.
When I tried that the control panel move Z in the opposite direction,
When I run/ machine the design it lifts up and never touches the material at all.

Please help me, I am sure it is just an ID10t error on my part. probably just one small thing I am missing.

Some pictures enclosed below.

Thanks in advance for any and all help
George in NEPA

That is usually how it behaves if it has an endstop on it wired incorrectly.

I do not have end stops on my machine.

this is a really cool machine, but I need help getting it to work correctly.

In Estlcam, under Basic Settings, what do you have in the Clearance plane box?

All of my Z-axis issues thus far have been due to a loose connection between the stepper and wiring harness. Black tape didnt work for me so I used a zip tie as shown inthis post.

Hi . I have the almost the same problem did you resolve it , the z axis seem to move a fraction like a micro movement , are you trying in estlecam or using nc file in repetier host .

PS . i have 6mm clearance in ectlcam , when i connect in repetier host the connectbutton stays green and it sounds sound like a click but ant move manualy in program . please any help , so close yet so far lol

How fast are you trying to move it, have you lubed the screw, checked for any interferences?

Those are the top three issues in order or occurrence.

the z axis moves with manual control in estlcam but when trying to do a test piece with a pen it only moves a fraction . x and y work fine . have set max z speed to 8 mm per second

don’t understand why when in repetier host it clicks but wont move on any axis i have set all settings as you have stated in basic set up in repetier host and light is green on connect icon. in estlcam x and y work fine but z axis moves a tenth if that of what it should be . frustratingly close now .

I am not clear on the issue. If you are using estlcam to control the machine it is a different story. If you are using repetier I can easily help you. You can’t use both.

What firmware are you using?

the issue is the mpcnc seems to do very little in repetier host , mpcnc just clicks once when connected and light is green. so i tried your full logo in estlcam worked but z axis not moving just tiny 0.1mm movements so pen wont leave paper . in estlacm the manual moment on all axis work in rh nothing . just want to get one to work . im happy to use repetier could not get to work so tried estlcam thats all . apologies as a noob to this set repetier setting as stated in tutorial resistor in place

i bought kit from you so flashed already , got ardunio, repetier host , estlcam on laptop

Here is my normal workflow…
I load a picture (dxf) in estlcam. Pick my bit/tool.
Then I use estlcam to generate the path for the tool to follow.
Then save off the path to an .nc file.
The I switch to repetier host and connect to the machine
Then load the .nc file that estlcam saved
Then power the router and hit play/start in repetier host…

Is that the sequence you are following?

Here’s the other question that springs to mind…
estlcam has an option to download firmware to the Cnc… did you happen to do that? That firmware isn’t (to my knowledge) able to control the mpcnc completely yet.

In the Basic Setting in Estlcam v10, my Clearance Plane is set to 5.00mm.
I think that is how it was I do not remember changing it.

What should it be?

I am using Estlcam v10. The control panel in program moves all the X, Y, and Z fine and in the right directions.
When I save as a program and click machine program, the preview pops up and if I use the tilt view arrows it looks like it is lifting high enough above the work piece.
Then I click OK and the control panel pops up with the program loaded and I click the play/ run button on bottom right and it moves in X and Y correctly, but Z is not going up and down as it should.
It does not lift up and the bit cuts along as it moves to the next section to be cut.
So I have these cuts along the same paths that it shows in the preview.

As far as how fast am I how fast am trying to move it.
I just selected the bit from the tool list and then selected the type of cut I want to make. I have not set any speeds. I thought it was set by selecting the bit. it shows numbers in the boxes for that bit.

Yes I have greased the screw. That was in the instructions.

I am not sure what interference you are referring to.
All the wire harnesses move freely.

George im sorry for jumping on your thread but it seems like we have the almost the same problem i did update the firmware in estlcam so will i have to re flash firmware ?

I checked my wire harness plugs On Z and the plugs are still very snug together with the electrical tape.
I will keep this in mind if I have an issue in the future.

Sounds like you both are using the estlcam firmware. I don’t have enough experience with it to really understand what could be happening.

It would be best for you both to re-flash your arduino’s back to my firmware.